summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-05-31 15:53:47 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-05-31 16:09:19 +0200
commitdd15d0ffecb988ecaee37379f5e85d9bdfe2fe89 (patch)
tree41f2a900bbaf6e06d99cc0c1092bfdaf5d06ccbc /gnu
parent12e6a5923812abf180f03bea9e07dd99244a3fcd (diff)
downloadguix-patches-dd15d0ffecb988ecaee37379f5e85d9bdfe2fe89.tar
guix-patches-dd15d0ffecb988ecaee37379f5e85d9bdfe2fe89.tar.gz
gnu: btrfs-progs: Fix build.
* gnu/packages/linux.scm (btrfs-progs)[arguments]<#:configure-flags>: Fix typo. Splicing MEMBER return value results in an invalid IF form. The whole IF should be spliced instead. Reported-by: mrvdb on #guix.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/linux.scm10
1 files changed, 5 insertions, 5 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index cef0c4d72f..28988e0101 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -5926,18 +5926,18 @@ and copy/paste text in the console and in xterm.")
(arguments
(list
#:configure-flags
- #~(append
+ #~(list
;; Without --disable-documentation, it complains about missing
;; python-sphinx on systems where this package isn't available
;; (because it requires Rust).
- (if #$@(member (%current-system)
+ #$@(if (member (%current-system)
(package-transitive-supported-systems
python-sphinx))
- '()
- (list "--disable-documentation"))
+ '()
+ '("--disable-documentation"))
;; The ‘Python support’ was never actually installed by previous
;; versions of this package, but did prevent cross-compilation.
- (list "--disable-python"))
+ "--disable-python")
#:phases #~(modify-phases %standard-phases
(add-after 'unpack 'patch-makefile
(lambda* (#:key outputs #:allow-other-keys)