summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
author宋文武 <iyzsong@member.fsf.org>2023-05-24 21:38:35 +0800
committer宋文武 <iyzsong@member.fsf.org>2023-05-30 17:46:43 +0800
commitd32fb0ee6bc6bdd91b55a52d03cc32075b55f49b (patch)
tree9eb04c528c42f5bb37f49f10672872f4c628755b /gnu
parent368f0fa0f2e2017e45b226f96b1f367bda04bdfd (diff)
downloadguix-patches-d32fb0ee6bc6bdd91b55a52d03cc32075b55f49b.tar
guix-patches-d32fb0ee6bc6bdd91b55a52d03cc32075b55f49b.tar.gz
gnu: warzone2100: Rewrite package arguments to G-expressions.
* gnu/packages/games.scm (warzone2100)[arguments]: Convert to list of G-expressions.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/games.scm48
1 files changed, 24 insertions, 24 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index eb3e0eb842..862aa26805 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -5414,30 +5414,30 @@ in-window at 640x480 resolution or fullscreen.")
#t))))
(build-system cmake-build-system)
(arguments
- `(#:configure-flags '("-DWZ_DISTRIBUTOR=Guix"
- "-DWZ_ENABLE_BACKEND_VULKAN=off"
- "-DENABLE_DISCORD=off")
- #:tests? #f ; TODO: Tests seem to be broken, configure.ac is missing.
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'fix-utfcpp-include
- (lambda _
- (substitute* "lib/framework/wzstring.cpp"
- (("<utfcpp/source/utf8.h>") "<utf8.h>"))
- #t))
- (add-after 'unpack 'link-tests-with-qt
- (lambda _
- (substitute* "tests/Makefile.am"
- (("(framework_linktest_LDADD|maptest_LDADD) = " prefix)
- (string-append prefix "$(QT5_LIBS) ")))
- #t))
- (add-after 'unpack 'fix-ivis-linktest
- (lambda _
- (substitute* "tests/ivis_linktest.cpp"
- (("iV_DrawTextRotated.*;")
- (string-append "iV_DrawTextRotated(\"Press ESC to exit.\", "
- "100, 100, 0.0f, font_regular);")))
- #t)))))
+ (list #:configure-flags #~'("-DWZ_DISTRIBUTOR=Guix"
+ "-DWZ_ENABLE_BACKEND_VULKAN=off"
+ "-DENABLE_DISCORD=off")
+ #:tests? #f ; TODO: Tests seem to be broken, configure.ac is missing.
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'fix-utfcpp-include
+ (lambda _
+ (substitute* "lib/framework/wzstring.cpp"
+ (("<utfcpp/source/utf8.h>")
+ "<utf8.h>"))))
+ (add-after 'unpack 'link-tests-with-qt
+ (lambda _
+ (substitute* "tests/Makefile.am"
+ (("(framework_linktest_LDADD|maptest_LDADD) = "
+ prefix)
+ (string-append prefix "$(QT5_LIBS) ")))))
+ (add-after 'unpack 'fix-ivis-linktest
+ (lambda _
+ (substitute* "tests/ivis_linktest.cpp"
+ (("iV_DrawTextRotated.*;")
+ (string-append
+ "iV_DrawTextRotated(\"Press ESC to exit.\", "
+ "100, 100, 0.0f, font_regular);"))))))))
(native-inputs (list asciidoc
ruby-asciidoctor
gettext-minimal