summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2023-04-01 16:13:13 +0200
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-04-14 15:12:10 -0400
commitd06bcd603117c26b41267ba59220b8564504b749 (patch)
tree791f3e5f1b27f39329acec84b1497826266c405c /gnu
parent15c7b48333d068a7240f667430830e95fae3556b (diff)
downloadguix-patches-d06bcd603117c26b41267ba59220b8564504b749.tar
guix-patches-d06bcd603117c26b41267ba59220b8564504b749.tar.gz
gnu: Add mecab.
* gnu/packages/language.scm (mecab): New variable. * gnu/packages/patches/mecab-variable-param.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/language.scm52
1 files changed, 0 insertions, 52 deletions
diff --git a/gnu/packages/language.scm b/gnu/packages/language.scm
index 208fab4f5b..88fb43b9bc 100644
--- a/gnu/packages/language.scm
+++ b/gnu/packages/language.scm
@@ -979,55 +979,3 @@ fi")))))))
collaboration between the Kyoto university and Nippon Telegraph and Telephone
Corporation. The engine is independent of any language, dictionary or corpus.")
(license (list license:gpl2+ license:lgpl2.1+ license:bsd-3))))
-
-(define-public mecab-ipadic
- (package
- (name "mecab-ipadic")
- (version "2.7.0")
- (source (package-source mecab))
- (build-system gnu-build-system)
- (arguments
- `(#:configure-flags
- (list (string-append "--with-dicdir=" (assoc-ref %outputs "out")
- "/lib/mecab/dic")
- "--with-charset=utf8")
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'chdir
- (lambda _
- (chdir "mecab-ipadic")))
- (add-before 'configure 'set-mecab-dir
- (lambda* (#:key outputs #:allow-other-keys)
- (setenv "MECAB_DICDIR" (string-append (assoc-ref outputs "out")
- "/lib/mecab/dic")))))))
- (native-inputs (list mecab)); for mecab-config
- (home-page "https://taku910.github.io/mecab")
- (synopsis "Dictionary data for MeCab")
- (description "This package contains dictionnary data derived from
-ipadic for use with MeCab.")
- (license (license:non-copyleft "mecab-ipadic/COPYING"))))
-
-(define-public mecab-unidic
- (package
- (name "mecab-unidic")
- (version "3.1.0")
- (source (origin
- (method url-fetch)
- (uri (string-append "https://clrd.ninjal.ac.jp/unidic_archive/cwj/"
- version "/unidic-cwj-" version ".zip"))
- (sha256
- (base32
- "1z132p2q3bgchiw529j2d7dari21kn0fhkgrj3vcl0ncg2m521il"))))
- (build-system copy-build-system)
- (arguments
- `(#:install-plan
- '(("." "lib/mecab/dic"
- #:include-regexp ("\\.bin$" "\\.def$" "\\.dic$" "dicrc")))))
- (native-inputs (list unzip))
- (home-page "https://clrd.ninjal.ac.jp/unidic/en/")
- (synopsis "Dictionary data for MeCab")
- (description "UniDic for morphological analysis is a dictionary for
-analysis with the morphological analyser MeCab, where the short units exported
-from the database are used as entries (heading terms).")
- ;; triple-licensed (at the user’s choice)
- (license (list license:gpl2+ license:lgpl2.1 license:bsd-3))))