summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorKyle Andrews <kyle@posteo.net>2023-04-01 04:57:00 +0000
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-04-14 15:12:12 -0400
commitb4f5ec676005a01e47ace652ba722f8f1d5d2ec5 (patch)
treea976d91f3486b571c5ac4b716f6ac97c8c141f29 /gnu
parent99438cf1190b7fab3d2030d92de0cb8443fd2dd8 (diff)
downloadguix-patches-b4f5ec676005a01e47ace652ba722f8f1d5d2ec5.tar
guix-patches-b4f5ec676005a01e47ace652ba722f8f1d5d2ec5.tar.gz
gnu: Add r-targets.
* gnu/packages/cran.scm (r-targets): New variable., Signed-off-by: Ricardo Wurmus <rekado@elephly.net>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cran.scm37
1 files changed, 0 insertions, 37 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 8c631bdccd..6eb5a99343 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -14457,43 +14457,6 @@ equations, and Cox proportional hazards models. Functions are available to
handle data from simple random samples as well as complex surveys.")
(license license:gpl3+)))
-(define-public r-tarchetypes
- (package
- (name "r-tarchetypes")
- (version "0.7.5")
- (source (origin
- (method url-fetch)
- (uri (cran-uri "tarchetypes" version))
- (sha256
- (base32
- "05yhq8xnrpk37x7fq0yjw4m527ji28s16dskfmljrbrzb064nw2g"))))
- (properties `((upstream-name . "tarchetypes")))
- (build-system r-build-system)
- (propagated-inputs (list r-digest
- r-dplyr
- r-fs
- r-furrr
- r-future
- r-future-callr
- r-rlang
- r-targets
- r-tibble
- r-tidyselect
- r-vctrs
- r-withr))
- (home-page "https://docs.ropensci.org/tarchetypes/")
- (synopsis "Archetypes for Targets")
- (description
- "Function-oriented Make-like declarative pipelines for statistics and
-data science are supported in the targets R package. As an extension to
-targets, the tarchetypes package provides convenient user-side functions to
-make targets easier to use. By establishing reusable archetypes for common
-kinds of targets and pipelines, these functions help express complicated
-reproducible pipelines concisely and compactly. The methods in this package
-were influenced by the drake R package by Will Landau (2018)
-<doi:10.21105/joss.00550>.")
- (license license:expat)))
-
(define-public r-targets
(package
(name "r-targets")