summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorTanguy Le Carrour <tanguy@bioneland.org>2020-08-27 16:41:14 +0200
committerLeo Famulari <leo@famulari.name>2020-08-27 12:26:18 -0400
commitf2d70885c3e8b856d91b33801ba701a0038a0814 (patch)
treea0ff3131874064293205b20c0320cf16599166dd /gnu
parent35988130c9e485826154f29ff67ce0e1b7c88fbc (diff)
downloadguix-patches-f2d70885c3e8b856d91b33801ba701a0038a0814.tar
guix-patches-f2d70885c3e8b856d91b33801ba701a0038a0814.tar.gz
gnu: Add python-dparse.
* gnu/packages/python-xyz.scm (python-dparse): New variable. Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index e32d7771cf..26ee801419 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -21750,3 +21750,26 @@ It adds a simple and readable way to print stuff during development.")
"@code{python-dateparser} provides modules to easily parse localized
dates in almost any string formats commonly found on web pages.")
(license license:bsd-3)))
+
+(define-public python-dparse
+ (package
+ (name "python-dparse")
+ (version "0.5.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "dparse" version))
+ (sha256
+ (base32
+ "0rzkg3nymsbwdjc0ms2bsajkda02jipwyp3xk97qj71f21lz3dd1"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("python-pytest" ,python-pytest)))
+ (propagated-inputs
+ `(("python-packaging" ,python-packaging)
+ ("python-pyyaml" ,python-pyyaml)
+ ("python-toml" ,python-toml)))
+ (home-page "https://github.com/pyupio/dparse")
+ (synopsis "Parser for Python dependency files")
+ (description "This package provides a parser for Python dependency files.")
+ (license license:expat)))