summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-03-06 23:00:38 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-03-07 20:10:31 -0500
commit85ce86238945ebfdad5bcc2754f50137400aa8c8 (patch)
treee94f3e7fd2770d4b384b3296fb1fb67219454435 /gnu
parentfa3b10539768f923f16de61f2d4b56cd7b61b471 (diff)
downloadguix-patches-85ce86238945ebfdad5bcc2754f50137400aa8c8.tar
guix-patches-85ce86238945ebfdad5bcc2754f50137400aa8c8.tar.gz
gnu: qtdeclarative: Update to 6.3.2.
* gnu/packages/qt.scm (qtdeclarative): Update to 6.3.2. [arguments]: Refine comment about build time. Remove dead code. Re-instate the tst_qqmlprofilerservice test in check phase.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/qt.scm13
1 files changed, 5 insertions, 8 deletions
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index d3666ebb69..ec0311ab59 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -1232,18 +1232,20 @@ with JavaScript and C++.")))
(define-public qtdeclarative
(package
(name "qtdeclarative")
- (version "6.3.1")
+ (version "6.3.2")
;; TODO: Package 'masm' and unbundle from sources.
(source (origin
(method url-fetch)
(uri (qt-urls name version))
(sha256
(base32
- "1s268fha3650dn1lqxf8jfa07wxpw09f6p7rjyiwq3w24d0nkrq3"))))
+ "1hbw63828pp8vm9b46i2pkcbcpr4mq9nblhmpwrw2pflq0fi24xq"))))
(build-system cmake-build-system)
(arguments
(list
- #:configure-flags #~(list "-GNinja" ;about twice as fast!
+ ;; The build takes 12 minutes on a Ryzen 3900X when building with Ninja,
+ ;; compared to 24 minutes with Make.
+ #:configure-flags #~(list "-GNinja"
"-DQT_BUILD_TESTS=ON")
#:phases
#~(modify-phases %standard-phases
@@ -1284,7 +1286,6 @@ with JavaScript and C++.")))
(when tests?
;; The tests expect to find the modules provided by this
;; package; extend the environment variables needed to do so.
- ;(setenv "CMAKE_PREFIX_PATH" #$output)
(setenv "QML2_IMPORT_PATH"
(string-append #$output "/lib/qt6/qml"))
(setenv "QT_PLUGIN_PATH"
@@ -1322,10 +1323,6 @@ with JavaScript and C++.")))
;; qrc). Import paths used:
;; /gnu/store/...-qtbase-6.3.1/lib/qt6/qml"
"tst_qmltc_qprocess"
- ;; This test is non-deterministic; may fail under high
- ;; load (see:
- ;; https://bugreports.qt.io/browse/QTBUG-111008).
- "tst_qqmlprofilerservice"
;; This one also causes non-determinstic failures (see:
;; https://bugreports.qt.io/browse/QTBUG-101488).
"tst_qquickfolderdialogimpl"