summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2022-07-07 10:09:05 +0200
committerPierre Neidhardt <mail@ambrevar.xyz>2022-07-08 19:32:44 +0200
commitbaed82efa7d3ad714d40e38c59808c1e82e708d7 (patch)
tree2f8199d6c279c410b43ef6143093b0e510c1fb43 /gnu
parentffc6e0a391b76fc96b4311081f580a1e6f7e3d8d (diff)
downloadguix-patches-baed82efa7d3ad714d40e38c59808c1e82e708d7.tar
guix-patches-baed82efa7d3ad714d40e38c59808c1e82e708d7.tar.gz
gnu: sbcl-xlunit: Remove Make reference from closure.
* gnu/packages/lisp-check.scm (sbcl-xlunit)[source]: Delete the 'debian' folder. This takes the closure size from 209 MiB down to 151 MiB.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/lisp-check.scm8
1 files changed, 7 insertions, 1 deletions
diff --git a/gnu/packages/lisp-check.scm b/gnu/packages/lisp-check.scm
index b52f44e23f..39f7d8ca61 100644
--- a/gnu/packages/lisp-check.scm
+++ b/gnu/packages/lisp-check.scm
@@ -941,7 +941,13 @@ parameterization.")
(file-name (git-file-name name version))
(sha256
(base32
- "0argfmp9nghs4sihyj3f8ch9qfib2b7ll07v5m9ziajgzsfl5xw3"))))
+ "0argfmp9nghs4sihyj3f8ch9qfib2b7ll07v5m9ziajgzsfl5xw3"))
+ (modules '((guix build utils)))
+ (snippet
+ ;; The useless bundled debian folder drags `make' into the closure.
+ `(begin
+ (delete-file-recursively "debian")
+ #t))))
(build-system asdf-build-system/sbcl)
(arguments
'(#:phases