summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLiliana Marie Prikler <liliana.prikler@gmail.com>2022-07-08 21:10:08 +0200
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2022-07-09 10:41:40 +0200
commit7e0440255fd1c5d954a7d22fed7e0438edf76b83 (patch)
treea25fa942b196c988f630b67987b1ab1df44bcc7a /gnu
parente47d0cfbb9a97326d682649f1f2236259d102231 (diff)
downloadguix-patches-7e0440255fd1c5d954a7d22fed7e0438edf76b83.tar
guix-patches-7e0440255fd1c5d954a7d22fed7e0438edf76b83.tar.gz
gnu: totem: Also wrap GI_TYPELIB_PATH.
* gnu/packages/gnome.scm (totem)[wrap-totem]: Add GI_TYPELIB_PATH with a suffix capturing the build path.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gnome.scm2
1 files changed, 2 insertions, 0 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index bb503fb371..f4e7b76a27 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -6209,9 +6209,11 @@ discovery protocols.")
'install 'wrap-totem
(lambda* (#:key inputs outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out"))
+ (gi-typelib-path (getenv "GI_TYPELIB_PATH"))
(gst-plugin-path (getenv "GST_PLUGIN_SYSTEM_PATH"))
(grl-plugin-path (getenv "GRL_PLUGIN_PATH")))
(wrap-program (string-append out "/bin/totem")
+ `("GI_TYPELIB_PATH" ":" suffix (,gi-typelib-path))
`("GST_PLUGIN_SYSTEM_PATH" ":" prefix (,gst-plugin-path))
`("GRL_PLUGIN_PATH" ":" prefix (,grl-plugin-path)))
(wrap-program (string-append out "/bin/totem-video-thumbnailer")