summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2022-07-08 11:43:36 +0200
committerPierre Neidhardt <mail@ambrevar.xyz>2022-07-08 19:32:45 +0200
commit1ae539eb4fbc9a007f986442d66cd56456045c5a (patch)
tree5222afe1ce8e6d7e68950debb9b019a3c2397849 /gnu
parent10ededddd3805b6ba945c9af3f059d8a4ca330fd (diff)
downloadguix-patches-1ae539eb4fbc9a007f986442d66cd56456045c5a.tar
guix-patches-1ae539eb4fbc9a007f986442d66cd56456045c5a.tar.gz
gnu: sbcl-dexador: Remove unneeded depedencies to reduce closure size.
* gnu/packages/lisp-xyz.scm (sbcl-dexador)[native-inputs]: Comment out. This takes the closure size from 357 MiB down to 342 MiB.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/lisp-xyz.scm18
1 files changed, 9 insertions, 9 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 96a4c8bd5b..705c68e10e 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -6127,15 +6127,15 @@ cookie headers, cookie creation, cookie jar creation and more.")
sbcl-trivial-gray-streams
sbcl-trivial-mimes
sbcl-usocket))
- (native-inputs
- (list sbcl-alexandria
- sbcl-babel
- sbcl-cl-ppcre
- sbcl-clack
- sbcl-lack
- sbcl-local-time
- sbcl-prove
- sbcl-trivial-features))
+ ;; These native-inputs are for tests only, which are disabled.
+ ;; Leave them commented since they add a lot to the closure size.
+ ;; (native-inputs
+ ;; (list sbcl-cl-ppcre
+ ;; sbcl-clack
+ ;; sbcl-lack
+ ;; sbcl-local-time
+ ;; sbcl-prove
+ ;; sbcl-trivial-features))
(arguments
;; TODO: Circular dependency: tests depend on clack-test which depends on dexador.
`(#:tests? #f