summaryrefslogtreecommitdiff
path: root/gnu/tests
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2021-10-10 13:54:07 +0200
committerMarius Bakke <marius@gnu.org>2021-10-11 18:59:44 +0200
commit93f69b02a290e0c82a4d166d84e1cbe056e6cc18 (patch)
tree8adc72153ae647cffbf5cad1eb5e75fd0ee55599 /gnu/tests
parentfafa127d80d41df8afe96357ab30ec3dc6499122 (diff)
downloadguix-patches-93f69b02a290e0c82a4d166d84e1cbe056e6cc18.tar
guix-patches-93f69b02a290e0c82a4d166d84e1cbe056e6cc18.tar.gz
gnu: ganeti: Update to 3.0.1.
* gnu/packages/virtualization.scm (ganeti): Update to 3.0.1. [source](patches): Remove obsolete. * gnu/tests/ganeti.scm (%ganeti-os): Adjust network configuration so QEMU port forwarding can work. (run-ganeti-test): Remove unused port mapping. Adjust and enable previously failing test. * gnu/packages/patches/ganeti-deterministic-manual.patch, gnu/packages/patches/ganeti-drbd-compat.patch, gnu/packages/patches/ganeti-os-disk-size.patch: Delete files. * gnu/local.mk (dist_patch_DATA): Adjust accordingly.
Diffstat (limited to 'gnu/tests')
-rw-r--r--gnu/tests/ganeti.scm33
1 files changed, 16 insertions, 17 deletions
diff --git a/gnu/tests/ganeti.scm b/gnu/tests/ganeti.scm
index b64a332dde..5ac2fd48dd 100644
--- a/gnu/tests/ganeti.scm
+++ b/gnu/tests/ganeti.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2020 Marius Bakke <marius@gnu.org>.
+;;; Copyright © 2020, 2021 Marius Bakke <marius@gnu.org>
;;; Copyright © 2020 Brice Waegeneire <brice@waegenei.re>
;;;
;;; This file is part of GNU Guix.
@@ -52,17 +52,17 @@
(hosts-file (plain-file "hosts" (format #f "
127.0.0.1 localhost
::1 localhost
-10.0.2.2 gnt1.example.com gnt1
+10.0.2.15 gnt1.example.com gnt1
192.168.254.254 ganeti.example.com
")))
(packages (append (list ganeti-instance-debootstrap ganeti-instance-guix)
%base-packages))
(services
- (append (list (static-networking-service "eth0" "10.0.2.2"
+ (append (list (static-networking-service "eth0" "10.0.2.15"
#:netmask "255.255.255.0"
- #:gateway "10.0.2.1"
- #:name-servers '("10.0.2.1"))
+ #:gateway "10.0.2.2"
+ #:name-servers '("10.0.2.3"))
(service openssh-service-type
(openssh-configuration
@@ -83,8 +83,7 @@
(master-netdev "eth0")
(hvparams '())
(extra-packages '())
- (rapi-port 5080)
- (noded-port 1811))
+ (rapi-port 5080))
"Run tests in %GANETI-OS."
(define os
(marionette-operating-system
@@ -96,7 +95,6 @@
(guix combinators))))
(define %forwarded-rapi-port 5080)
- (define %forwarded-noded-port 1811)
(define vm
(virtual-machine
@@ -104,14 +102,14 @@
;; Some of the daemons are fairly memory-hungry.
(memory-size 512)
;; Forward HTTP ports so we can access them from the "outside".
- (port-forwardings `((,%forwarded-rapi-port . ,rapi-port)
- (,%forwarded-noded-port . ,noded-port)))))
+ (port-forwardings `((,%forwarded-rapi-port . ,rapi-port)))))
(define test
(with-imported-modules '((gnu build marionette))
#~(begin
(use-modules (srfi srfi-11) (srfi srfi-64)
(web uri) (web client) (web response)
+ (ice-9 iconv)
(gnu build marionette))
(define marionette
@@ -213,18 +211,19 @@
"watcher" "continue"))
marionette))
- ;; Try accessing the RAPI. This causes an expected failure:
- ;; https://github.com/ganeti/ganeti/issues/1502
- ;; Run it anyway for easy testing of potential fixes.
+ ;; Try accessing the RAPI.
(test-equal "http-get RAPI version"
- '(200 "2")
+ '(200 "2\n")
(let-values
(((response text)
(http-get #$(simple-format
#f "http://localhost:~A/version"
%forwarded-rapi-port)
- #:decode-body? #t)))
- (list (response-code response) text)))
+ #:decode-body? #f)))
+ (list (response-code response)
+ ;; The API response lacks a content-type, so
+ ;; (http-client) won't decode it for us.
+ (bytevector->string text "UTF-8"))))
(test-equal "gnt-os list"
"debootstrap+default\nguix+default\n"
@@ -249,7 +248,7 @@
marionette))
(test-end)
- (exit (= (test-runner-fail-count (test-runner-current)) 1)))))
+ (exit (= (test-runner-fail-count (test-runner-current)) 0)))))
(gexp->derivation (string-append "ganeti-" hypervisor "-test") test))