summaryrefslogtreecommitdiff
path: root/gnu/system/shadow.scm
diff options
context:
space:
mode:
authorAlex Kost <alezost@gmail.com>2016-04-03 10:27:45 +0300
committerAlex Kost <alezost@gmail.com>2016-04-03 10:37:44 +0300
commitf8835ff4b3dd59d59bf44838d05d3d60114d15d2 (patch)
treea16bdafd7201b3e8e4f3f713317ae23c6748a282 /gnu/system/shadow.scm
parentea5d388257664d703df23cf3eb0da7b6546d6c42 (diff)
downloadguix-patches-f8835ff4b3dd59d59bf44838d05d3d60114d15d2.tar
guix-patches-f8835ff4b3dd59d59bf44838d05d3d60114d15d2.tar.gz
gnu: fontconfig: Find fonts in the system profile.
Fixes <http://bugs.gnu.org/22927>. Reported by myglc2 <myglc2@gmail.com>. This also reverts commit e71ef7adaece7e132a5059139122b45083ea1b39. * gnu/packages/fontutils.scm (fontconfig)[arguments]: Add /run/current-system/profile/share/fonts to --with-add-fonts configure flag. * gnu/system/shadow.scm (default-skeletons): Do not create "fonts.conf" file.
Diffstat (limited to 'gnu/system/shadow.scm')
-rw-r--r--gnu/system/shadow.scm23
1 files changed, 0 insertions, 23 deletions
diff --git a/gnu/system/shadow.scm b/gnu/system/shadow.scm
index a13ef1192c..6e62aeee57 100644
--- a/gnu/system/shadow.scm
+++ b/gnu/system/shadow.scm
@@ -131,12 +131,6 @@
(define (default-skeletons)
"Return the default skeleton files for /etc/skel. These files are copied by
'useradd' in the home directory of newly created user accounts."
- (define fonts.conf-content
- ;; SXML for ~/.config/fontconfig/fonts.conf. This works around the fact
- ;; that Fontconfig currently does not such this directory by default,
- ;; thereby ignoring fonts installed system-wide (FIXME).
- `(fontconfig (dir "/run/current-system/profile/share/fonts")))
-
(define copy-guile-wm
#~(begin
(use-modules (guix build utils))
@@ -180,22 +174,6 @@ source /etc/profile\n"))
(xdefaults (plain-file "Xdefaults" "\
XTerm*utf8: always
XTerm*metaSendsEscape: true\n"))
- (fonts.conf (computed-file
- "fonts.conf"
- #~(begin
- (use-modules (guix build utils)
- (sxml simple))
-
- (define dir
- (string-append #$output
- "/fontconfig"))
-
- (mkdir-p dir)
- (call-with-output-file (string-append dir
- "/fonts.conf")
- (lambda (port)
- (sxml->xml '#$fonts.conf-content port))))
- #:modules '((guix build utils))))
(gdbinit (plain-file "gdbinit" "\
# Tell GDB where to look for separate debugging files.
set debug-file-directory ~/.guix-profile/lib/debug\n")))
@@ -204,7 +182,6 @@ set debug-file-directory ~/.guix-profile/lib/debug\n")))
(".zlogin" ,zlogin)
(".Xdefaults" ,xdefaults)
(".guile-wm" ,guile-wm)
- (".config" ,fonts.conf)
(".gdbinit" ,gdbinit))))
(define (skeleton-directory skeletons)