summaryrefslogtreecommitdiff
path: root/gnu/system/examples/desktop.tmpl
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2016-03-22 23:48:21 +0100
committerLudovic Courtès <ludo@gnu.org>2016-03-23 00:23:12 +0100
commitd038b674cf3e44462814da70f68522d0e3aab018 (patch)
treebc63adcbb30070aa8ec7e588672dc43b50256b98 /gnu/system/examples/desktop.tmpl
parentd26e19671e2a50a25d37357aba301bef5df1818e (diff)
downloadguix-patches-d038b674cf3e44462814da70f68522d0e3aab018.tar
guix-patches-d038b674cf3e44462814da70f68522d0e3aab018.tar.gz
doc: Add "lightweight desktop" OS config example.
* gnu/system/examples/desktop.tmpl (packages): Remove XFCE and RATPOISON. (services): Add 'gnome-desktop-service' and 'xfce-desktop-service'. * gnu/system/examples/lightweight-desktop.tmpl: New file. * Makefile.am (EXAMPLES): Add it. * doc.am (OS_CONFIG_EXAMPLES_TEXI): Add doc/os-config-lightweight-desktop.texi. * gnu/system/install.scm (/etc/configuration-files)[directory]: Add lightweight-desktop.tmpl.
Diffstat (limited to 'gnu/system/examples/desktop.tmpl')
-rw-r--r--gnu/system/examples/desktop.tmpl20
1 files changed, 11 insertions, 9 deletions
diff --git a/gnu/system/examples/desktop.tmpl b/gnu/system/examples/desktop.tmpl
index 07183a533b..2fcf90f8b1 100644
--- a/gnu/system/examples/desktop.tmpl
+++ b/gnu/system/examples/desktop.tmpl
@@ -1,9 +1,9 @@
;; This is an operating system configuration template
-;; for a "desktop" setup with X11.
+;; for a "desktop" setup with GNOME and Xfce.
(use-modules (gnu) (gnu system nss))
(use-service-modules desktop)
-(use-package-modules xfce ratpoison certs)
+(use-package-modules certs)
(operating-system
(host-name "antelope")
@@ -29,15 +29,17 @@
(home-directory "/home/bob"))
%base-user-accounts))
- ;; Add Xfce and Ratpoison; that allows us to choose
- ;; sessions using either of these at the log-in screen.
- (packages (cons* xfce ratpoison ;desktop environments
- nss-certs ;for HTTPS access
+ ;; This is where we specify system-wide packages.
+ (packages (cons* nss-certs ;for HTTPS access
%base-packages))
- ;; Use the "desktop" services, which include the X11
- ;; log-in service, networking with Wicd, and more.
- (services %desktop-services)
+ ;; Add GNOME and/or Xfce---we can choose at the log-in
+ ;; screen with F1. Use the "desktop" services, which
+ ;; include the X11 log-in service, networking with Wicd,
+ ;; and more.
+ (services (cons* (gnome-desktop-service)
+ (xfce-desktop-service)
+ %desktop-services))
;; Allow resolution of '.local' host names with mDNS.
(name-service-switch %mdns-host-lookup-nss))