summaryrefslogtreecommitdiff
path: root/gnu/system/examples/bare-bones.tmpl
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-05-09 23:16:11 +0200
committerLudovic Courtès <ludo@gnu.org>2015-05-09 23:53:36 +0200
commit36ffaca2469e6a98e23f59c4a7e82ed985710310 (patch)
treeedcc607f08d79f9aafce3917a21b0de303f2aa4b /gnu/system/examples/bare-bones.tmpl
parentc217cbd84d7aee7414945a6cf85e1d704fff6e32 (diff)
downloadguix-patches-36ffaca2469e6a98e23f59c4a7e82ed985710310.tar
guix-patches-36ffaca2469e6a98e23f59c4a7e82ed985710310.tar.gz
doc: Add desktop configuration example.
* gnu/system/examples/bare-bones.tmpl: Change 'packages' and 'host-name'. Remove D-Bus, Avahi, and SLiM services, and add lsh instead. * gnu/system/examples/desktop.tmpl: New file. * Makefile.am (EXAMPLES): Add it.
Diffstat (limited to 'gnu/system/examples/bare-bones.tmpl')
-rw-r--r--gnu/system/examples/bare-bones.tmpl23
1 files changed, 11 insertions, 12 deletions
diff --git a/gnu/system/examples/bare-bones.tmpl b/gnu/system/examples/bare-bones.tmpl
index e14c95733a..8f4faca2d3 100644
--- a/gnu/system/examples/bare-bones.tmpl
+++ b/gnu/system/examples/bare-bones.tmpl
@@ -1,12 +1,13 @@
-;; This is an operating system configuration template.
+;; This is an operating system configuration template
+;; for a "bare bones" setup, with no X11 display server.
(use-modules (gnu))
-(use-service-modules xorg networking dbus avahi)
-(use-package-modules xorg avahi)
+(use-service-modules networking ssh)
+(use-package-modules admin)
(operating-system
- (host-name "antelope")
- (timezone "Europe/Paris")
+ (host-name "komputilo")
+ (timezone "Europe/Berlin")
(locale "en_US.UTF-8")
;; Assuming /dev/sdX is the target hard disk, and "root" is
@@ -36,12 +37,10 @@
(home-directory "/home/alice"))))
;; Globally-installed packages.
- (packages (cons xterm %base-packages))
+ (packages (cons tcpdump %base-packages))
- ;; Add services to the baseline: the SLiM log-in manager
- ;; for Xorg sessions, a DHCP client, Avahi, and D-Bus.
- (services (cons* (slim-service)
- (dhcp-client-service)
- (avahi-service)
- (dbus-service (list avahi))
+ ;; Add services to the baseline: a DHCP client and
+ ;; an SSH server.
+ (services (cons* (dhcp-client-service)
+ (lsh-service #:port-number 2222)
%base-services)))