summaryrefslogtreecommitdiff
path: root/gnu/services/networking.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2016-07-22 18:57:40 -0400
committerLeo Famulari <leo@famulari.name>2016-07-22 18:58:31 -0400
commitd227260d2f7833b6bdc55b8e3792378626ef3b69 (patch)
tree26d47d5d8ee8efb102323bca215429a8f8fe1095 /gnu/services/networking.scm
parentd778fa5ff6f4a860919eaf13db3f84cfc68cbee8 (diff)
parent26ad4adb5568c6ff370f446431b079520fb09615 (diff)
downloadguix-patches-d227260d2f7833b6bdc55b8e3792378626ef3b69.tar
guix-patches-d227260d2f7833b6bdc55b8e3792378626ef3b69.tar.gz
Merge branch 'master' into core-updates
Resolved conflicts: * gnu/packages/scheme.scm: Conflict in import of (guix licenses). On master, "#:hide (openssl)" was used. On core-updates, "#:select (some licenses)" was used. The latter won the conflict. * gnu/packages/version-control.scm (git)[arguments]: Whitespace conflict in 'install-shell-completion.
Diffstat (limited to 'gnu/services/networking.scm')
-rw-r--r--gnu/services/networking.scm15
1 files changed, 15 insertions, 0 deletions
diff --git a/gnu/services/networking.scm b/gnu/services/networking.scm
index a77ed3bb80..71f49a03a5 100644
--- a/gnu/services/networking.scm
+++ b/gnu/services/networking.scm
@@ -39,13 +39,28 @@
#:use-module (srfi srfi-26)
#:use-module (ice-9 match)
#:export (%facebook-host-aliases
+ static-networking
static-networking-service
+ static-networking-service-type
dhcp-client-service
%ntp-servers
+
+ ntp-configuration
+ ntp-configuration?
ntp-service
+ ntp-service-type
+
+ tor-configuration
+ tor-configuration?
tor-hidden-service
tor-service
+ tor-service-type
+
+ bitlbee-configuration
+ bitlbee-configuration?
bitlbee-service
+ bitlbee-service-type
+
wicd-service
network-manager-service
connman-service))