summaryrefslogtreecommitdiff
path: root/gnu/platforms
diff options
context:
space:
mode:
authorJosselin Poiret <dev@jpoiret.xyz>2022-05-23 22:37:26 +0200
committerMathieu Othacehe <othacehe@gnu.org>2022-05-25 09:27:25 +0200
commitdab819d5c4c55609efae098c8e3c2f2757c34e5b (patch)
tree43691e8653b203da8cd5100085f67253ce48f2a7 /gnu/platforms
parentd129d962e437fd215c5e9428fc1b26e2d72ffbda (diff)
downloadguix-patches-dab819d5c4c55609efae098c8e3c2f2757c34e5b.tar
guix-patches-dab819d5c4c55609efae098c8e3c2f2757c34e5b.tar.gz
Move (gnu platform) and (gnu platforms ...) to guix/.
* gnu/platform.scm: * gnu/platforms/arm.scm: * gnu/platforms/hurd.scm: * gnu/platforms/mips.scm: * gnu/platforms/powerpc.scm: * gnu/platforms/riscv.scm: * gnu/platforms/s390.scm: * gnu/platforms/x86.scm: Move to guix/. * Makefile.am: * doc/guix.texi (Porting to a New Platform): * etc/release-manifest.scm: * gnu/ci.scm: * gnu/image.scm: * gnu/local.mk: * gnu/packages/bioinformatics.scm: * gnu/packages/bootstrap.scm: * gnu/packages/cross-base.scm: * gnu/packages/instrumentation.scm: * gnu/packages/linux.scm: * gnu/system/image.scm: * gnu/system/images/hurd.scm: * gnu/system/images/novena.scm: * gnu/system/images/pine64.scm: * gnu/system/images/pinebook-pro.scm: * gnu/system/images/rock64.scm: * guix/scripts/build.scm: * guix/scripts/system.scm: * guix/self.scm: Update (gnu platform...) to (guix platform...). Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
Diffstat (limited to 'gnu/platforms')
-rw-r--r--gnu/platforms/arm.scm38
-rw-r--r--gnu/platforms/hurd.scm29
-rw-r--r--gnu/platforms/mips.scm30
-rw-r--r--gnu/platforms/powerpc.scm38
-rw-r--r--gnu/platforms/riscv.scm30
-rw-r--r--gnu/platforms/s390.scm30
-rw-r--r--gnu/platforms/x86.scm59
7 files changed, 0 insertions, 254 deletions
diff --git a/gnu/platforms/arm.scm b/gnu/platforms/arm.scm
deleted file mode 100644
index bf68b2d00f..0000000000
--- a/gnu/platforms/arm.scm
+++ /dev/null
@@ -1,38 +0,0 @@
-;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2021 Mathieu Othacehe <othacehe@gnu.org>
-;;;
-;;; This file is part of GNU Guix.
-;;;
-;;; GNU Guix is free software; you can redistribute it and/or modify it
-;;; under the terms of the GNU General Public License as published by
-;;; the Free Software Foundation; either version 3 of the License, or (at
-;;; your option) any later version.
-;;;
-;;; GNU Guix is distributed in the hope that it will be useful, but
-;;; WITHOUT ANY WARRANTY; without even the implied warranty of
-;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-;;; GNU General Public License for more details.
-;;;
-;;; You should have received a copy of the GNU General Public License
-;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
-
-(define-module (gnu platforms arm)
- #:use-module (gnu platform)
- #:use-module (gnu packages linux)
- #:use-module (guix records)
- #:export (armv7-linux
- aarch64-linux))
-
-(define armv7-linux
- (platform
- (target "arm-linux-gnueabihf")
- (system "armhf-linux")
- (linux-architecture "arm")
- (glibc-dynamic-linker "/lib/ld-linux-armhf.so.3")))
-
-(define aarch64-linux
- (platform
- (target "aarch64-linux-gnu")
- (system "aarch64-linux")
- (linux-architecture "arm64")
- (glibc-dynamic-linker "/lib/ld-linux-aarch64.so.1")))
diff --git a/gnu/platforms/hurd.scm b/gnu/platforms/hurd.scm
deleted file mode 100644
index 328e9818ad..0000000000
--- a/gnu/platforms/hurd.scm
+++ /dev/null
@@ -1,29 +0,0 @@
-;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2021 Mathieu Othacehe <othacehe@gnu.org>
-;;;
-;;; This file is part of GNU Guix.
-;;;
-;;; GNU Guix is free software; you can redistribute it and/or modify it
-;;; under the terms of the GNU General Public License as published by
-;;; the Free Software Foundation; either version 3 of the License, or (at
-;;; your option) any later version.
-;;;
-;;; GNU Guix is distributed in the hope that it will be useful, but
-;;; WITHOUT ANY WARRANTY; without even the implied warranty of
-;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-;;; GNU General Public License for more details.
-;;;
-;;; You should have received a copy of the GNU General Public License
-;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
-
-(define-module (gnu platforms hurd)
- #:use-module (gnu platform)
- #:use-module (gnu packages linux)
- #:use-module (guix records)
- #:export (hurd))
-
-(define hurd
- (platform
- (target "i586-pc-gnu")
- (system "i586-gnu")
- (glibc-dynamic-linker "/lib/ld.so.1")))
diff --git a/gnu/platforms/mips.scm b/gnu/platforms/mips.scm
deleted file mode 100644
index 174657da13..0000000000
--- a/gnu/platforms/mips.scm
+++ /dev/null
@@ -1,30 +0,0 @@
-;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2022 Mathieu Othacehe <othacehe@gnu.org>
-;;;
-;;; This file is part of GNU Guix.
-;;;
-;;; GNU Guix is free software; you can redistribute it and/or modify it
-;;; under the terms of the GNU General Public License as published by
-;;; the Free Software Foundation; either version 3 of the License, or (at
-;;; your option) any later version.
-;;;
-;;; GNU Guix is distributed in the hope that it will be useful, but
-;;; WITHOUT ANY WARRANTY; without even the implied warranty of
-;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-;;; GNU General Public License for more details.
-;;;
-;;; You should have received a copy of the GNU General Public License
-;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
-
-(define-module (gnu platforms mips)
- #:use-module (gnu platform)
- #:use-module (gnu packages linux)
- #:use-module (guix records)
- #:export (mips64-linux))
-
-(define mips64-linux
- (platform
- (target "mips64el-linux-gnu")
- (system "mips64el-linux")
- (linux-architecture "mips")
- (glibc-dynamic-linker "/lib/ld.so.1")))
diff --git a/gnu/platforms/powerpc.scm b/gnu/platforms/powerpc.scm
deleted file mode 100644
index 1d0b5cb666..0000000000
--- a/gnu/platforms/powerpc.scm
+++ /dev/null
@@ -1,38 +0,0 @@
-;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2022 Mathieu Othacehe <othacehe@gnu.org>
-;;;
-;;; This file is part of GNU Guix.
-;;;
-;;; GNU Guix is free software; you can redistribute it and/or modify it
-;;; under the terms of the GNU General Public License as published by
-;;; the Free Software Foundation; either version 3 of the License, or (at
-;;; your option) any later version.
-;;;
-;;; GNU Guix is distributed in the hope that it will be useful, but
-;;; WITHOUT ANY WARRANTY; without even the implied warranty of
-;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-;;; GNU General Public License for more details.
-;;;
-;;; You should have received a copy of the GNU General Public License
-;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
-
-(define-module (gnu platforms powerpc)
- #:use-module (gnu platform)
- #:use-module (gnu packages linux)
- #:use-module (guix records)
- #:export (powerpc-linux
- powerpc64le-linux))
-
-(define powerpc-linux
- (platform
- (target "powerpc-linux-gnu")
- (system "powerpc-linux")
- (linux-architecture "powerpc")
- (glibc-dynamic-linker "/lib/ld.so.1")))
-
-(define powerpc64le-linux
- (platform
- (target "powerpc64le-linux-gnu")
- (system "powerpc64le-linux")
- (linux-architecture "powerpc")
- (glibc-dynamic-linker "/lib/ld64.so.2")))
diff --git a/gnu/platforms/riscv.scm b/gnu/platforms/riscv.scm
deleted file mode 100644
index c2b4850e55..0000000000
--- a/gnu/platforms/riscv.scm
+++ /dev/null
@@ -1,30 +0,0 @@
-;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2022 Mathieu Othacehe <othacehe@gnu.org>
-;;;
-;;; This file is part of GNU Guix.
-;;;
-;;; GNU Guix is free software; you can redistribute it and/or modify it
-;;; under the terms of the GNU General Public License as published by
-;;; the Free Software Foundation; either version 3 of the License, or (at
-;;; your option) any later version.
-;;;
-;;; GNU Guix is distributed in the hope that it will be useful, but
-;;; WITHOUT ANY WARRANTY; without even the implied warranty of
-;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-;;; GNU General Public License for more details.
-;;;
-;;; You should have received a copy of the GNU General Public License
-;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
-
-(define-module (gnu platforms riscv)
- #:use-module (gnu platform)
- #:use-module (gnu packages linux)
- #:use-module (guix records)
- #:export (riscv64-linux))
-
-(define riscv64-linux
- (platform
- (target "riscv64-linux-gnu")
- (system "riscv64-linux")
- (linux-architecture "riscv")
- (glibc-dynamic-linker "/lib/ld-linux-riscv64-lp64d.so.1")))
diff --git a/gnu/platforms/s390.scm b/gnu/platforms/s390.scm
deleted file mode 100644
index d3b1133974..0000000000
--- a/gnu/platforms/s390.scm
+++ /dev/null
@@ -1,30 +0,0 @@
-;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2022 Mathieu Othacehe <othacehe@gnu.org>
-;;;
-;;; This file is part of GNU Guix.
-;;;
-;;; GNU Guix is free software; you can redistribute it and/or modify it
-;;; under the terms of the GNU General Public License as published by
-;;; the Free Software Foundation; either version 3 of the License, or (at
-;;; your option) any later version.
-;;;
-;;; GNU Guix is distributed in the hope that it will be useful, but
-;;; WITHOUT ANY WARRANTY; without even the implied warranty of
-;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-;;; GNU General Public License for more details.
-;;;
-;;; You should have received a copy of the GNU General Public License
-;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
-
-(define-module (gnu platforms s390)
- #:use-module (gnu platform)
- #:use-module (gnu packages linux)
- #:use-module (guix records)
- #:export (s390x-linux))
-
-(define s390x-linux
- (platform
- (target "s390x-linux-gnu")
- (system "s390x-linux")
- (linux-architecture "s390")
- (glibc-dynamic-linker "/lib/ld64.so.1")))
diff --git a/gnu/platforms/x86.scm b/gnu/platforms/x86.scm
deleted file mode 100644
index fba7dd4fc0..0000000000
--- a/gnu/platforms/x86.scm
+++ /dev/null
@@ -1,59 +0,0 @@
-;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2022 Mathieu Othacehe <othacehe@gnu.org>
-;;;
-;;; This file is part of GNU Guix.
-;;;
-;;; GNU Guix is free software; you can redistribute it and/or modify it
-;;; under the terms of the GNU General Public License as published by
-;;; the Free Software Foundation; either version 3 of the License, or (at
-;;; your option) any later version.
-;;;
-;;; GNU Guix is distributed in the hope that it will be useful, but
-;;; WITHOUT ANY WARRANTY; without even the implied warranty of
-;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-;;; GNU General Public License for more details.
-;;;
-;;; You should have received a copy of the GNU General Public License
-;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
-
-(define-module (gnu platforms x86)
- #:use-module (gnu platform)
- #:use-module (gnu packages linux)
- #:use-module (guix records)
- #:export (i686-linux
- x86_64-linux
- i686-mingw
- x86_64-mingw
- hurd))
-
-(define i686-linux
- (platform
- (target "i686-linux-gnu")
- (system "i686-linux")
- (linux-architecture "i386")
- (glibc-dynamic-linker "/lib/ld-linux.so.2")))
-
-(define x86_64-linux
- (platform
- (target "x86_64-linux-gnu")
- (system "x86_64-linux")
- (linux-architecture "x86_64")
- (glibc-dynamic-linker "/lib/ld-linux-x86-64.so.2")))
-
-(define i686-mingw
- (platform
- (target "i686-w64-mingw32")
- (system #f)
- (glibc-dynamic-linker #f)))
-
-(define x86_64-mingw
- (platform
- (target "x86_64-w64-mingw32")
- (system #f)
- (glibc-dynamic-linker #f)))
-
-(define hurd
- (platform
- (target "i586-pc-gnu")
- (system "i586-gnu")
- (glibc-dynamic-linker "/lib/ld.so.1")))