summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-11-29 22:41:04 +0100
committerRicardo Wurmus <rekado@elephly.net>2018-11-29 22:43:49 +0100
commit743600e9db44e83819e3212646ad6deaa21453ec (patch)
tree417210aaaf13855b53b55d083ec048d494bdc631 /gnu/packages
parentba185e2a63d7f4f48238953bf062d4f84514bc5d (diff)
downloadguix-patches-743600e9db44e83819e3212646ad6deaa21453ec.tar
guix-patches-743600e9db44e83819e3212646ad6deaa21453ec.tar.gz
gnu: flameshot: Fetch sources from git.
* gnu/packages/image.scm (flameshot)[source]: Fetch from git.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/image.scm11
1 files changed, 6 insertions, 5 deletions
diff --git a/gnu/packages/image.scm b/gnu/packages/image.scm
index c5347d6082..33587bf01b 100644
--- a/gnu/packages/image.scm
+++ b/gnu/packages/image.scm
@@ -1457,13 +1457,14 @@ parsing, viewing, modifying, and saving this metadata.")
(version "0.5.1")
(source
(origin
- (method url-fetch)
- (uri (string-append "https://github.com/lupoDharkael/flameshot/archive/"
- "v" version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/lupoDharkael/flameshot.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
(base32
- "0kp451bqgssvg8n3sg60s3fifplm9l5kxiij0yxkl864p2mhw8im"))))
+ "13h77np93r796jf289v4r687cmnpqkyqs34dm9gif4akaig74ky0"))))
(build-system gnu-build-system)
(native-inputs
`(("qttools" ,qttools)))