summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2016-12-11 21:56:41 +0200
committerEfraim Flashner <efraim@flashner.co.il>2016-12-12 16:14:29 +0200
commita0bc2d45ebb2ba527ab556639d327d230147fcf9 (patch)
tree10f7172db06c4fb7a116c293e6e1f89ac9238a93 /gnu/packages
parentc5ea912016fdba6a1debe6eef7fbd51e59efb9a5 (diff)
downloadguix-patches-a0bc2d45ebb2ba527ab556639d327d230147fcf9.tar
guix-patches-a0bc2d45ebb2ba527ab556639d327d230147fcf9.tar.gz
gnu: python-pyqt@5.5: Remove variable.
* gnu/packages/qt.scm (python-pyqt@5.5, python2-pyqt@5.5): Remove them.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/qt.scm57
1 files changed, 0 insertions, 57 deletions
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 9988171a4b..f3ad193472 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -1061,63 +1061,6 @@ contain over 620 classes.")
`(("python" ,python-2)
,@(alist-delete "python" (package-inputs python-pyqt))))))
-(define-public python-pyqt-5.5
- (package (inherit python-pyqt)
- (version "5.5")
- (source
- (origin
- (method url-fetch)
- (uri
- (string-append "mirror://sourceforge/pyqt/PyQt5/"
- "PyQt-" version "/PyQt-gpl-"
- version ".tar.gz"))
- (sha256
- (base32
- "056qmkv02wdcfblqdaxiswrgn4wa88sz22i1x58dpb1iniavplfd"))
- (patches (search-patches "pyqt-configure.patch"))))
- (arguments
- `(#:modules ((srfi srfi-1)
- ,@%gnu-build-system-modules)
- #:phases
- (modify-phases %standard-phases
- (replace 'configure
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (bin (string-append out "/bin"))
- (sip (string-append out "/share/sip"))
- (plugins (string-append out "/plugins"))
- (designer (string-append plugins "/designer"))
- (qml (string-append plugins "/PyQt5"))
- (python (assoc-ref inputs "python"))
- (python-version
- (last (string-split python #\-)))
- (python-major+minor
- (string-join
- (take (string-split python-version #\.) 2)
- "."))
- (lib (string-append out "/lib/python"
- python-major+minor
- "/site-packages")))
- (zero? (system* "python" "configure.py"
- "--confirm-license"
- "--bindir" bin
- "--destdir" lib
- "--designer-plugindir" designer
- "--qml-plugindir" qml
- "--sipdir" sip))))))))
- (native-inputs
- `(("python-sip" ,python-sip)
- ("qt" ,qt)))))
-
-(define-public python2-pyqt-5.5
- (package (inherit python-pyqt-5.5)
- (name "python2-pyqt")
- (native-inputs
- `(("python-sip" ,python2-sip)
- ("qt" ,qt)))
- (inputs
- `(("python" ,python-2)))))
-
(define-public python-pyqt-4
(package (inherit python-pyqt)
(name "python-pyqt")