summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-06-26 21:25:03 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-06-27 00:34:27 +0100
commitf046e348e18939d3a891d5e183f83b3e75df2251 (patch)
treeb6cc5c630cdcf8b96152e2f6d04fc35a30d27167 /gnu/packages
parent9fb7946a232919844a600a3633a8944043085d3d (diff)
downloadguix-patches-f046e348e18939d3a891d5e183f83b3e75df2251.tar
guix-patches-f046e348e18939d3a891d5e183f83b3e75df2251.tar.gz
gnu: go-github-com-sasha-s-go-deadlock: Move to golang-check.
* gnu/packages/syncthing.scm (go-github-com-sasha-s-go-deadlock): Move from here ... * gnu/packages/golang-check.scm: ... to here. Change-Id: Id3d101897b4ac056cfe48a52289dd3e4f51402d8
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/golang-check.scm29
-rw-r--r--gnu/packages/syncthing.scm24
2 files changed, 28 insertions, 25 deletions
diff --git a/gnu/packages/golang-check.scm b/gnu/packages/golang-check.scm
index 502b09f7ab..7f741df698 100644
--- a/gnu/packages/golang-check.scm
+++ b/gnu/packages/golang-check.scm
@@ -1,9 +1,9 @@
;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2017, 2019 Leo Famulari <leo@famulari.name>
;;; Copyright © 2018 Christopher Baines <mail@cbaines.net>
;;; Copyright © 2018 Pierre Neidhardt <mail@ambrevar.xyz>
;;; Copyright © 2018 Pierre-Antoine Rouby <pierre-antoine.rouby@inria.fr>
;;; Copyright © 2019 Brian Leung <bkleung89@gmail.com>
-;;; Copyright © 2019 Leo Famulari <leo@famulari.name>
;;; Copyright © 2019 Vagrant Cascadian <vagrant@debian.org>
;;; Copyright © 2020 Jakub Kądziołka <kuba@kadziolka.net>
;;; Copyright © 2020 Joseph LaFreniere <joseph@lafreniere.xyz>
@@ -732,6 +732,7 @@ Go application.")
original value once the test has been run.")
(license license:expat)))
+<<<<<<< HEAD
(define-public go-github-com-petermattis-goid
(let ((commit "b0b1615b78e5ee59739545bb38426383b2cda4c9")
(revision "1"))
@@ -757,6 +758,32 @@ original value once the test has been run.")
"This package offers a method of programmatically retrieving the
current goroutine's ID.")
(license license:asl2.0))))
+=======
+(define-public go-github-com-sasha-s-go-deadlock
+ (package
+ (name "go-github-com-sasha-s-go-deadlock")
+ (version "0.2.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/sasha-s/go-deadlock")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "13p7b7pakd9k1c2k0fs1hfim3c8mivz679977ai6zb01s4aw7gyg"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/sasha-s/go-deadlock"))
+ (propagated-inputs
+ (list go-github-com-petermattis-goid))
+ (home-page "https://github.com/sasha-s/go-deadlock")
+ (synopsis "Deadlock detection in go")
+ (description
+ "This package provides tools for detecting deadlocks at run-time in Go.")
+ (license license:asl2.0)))
+>>>>>>> 23b9baa200 (gnu: go-github-com-sasha-s-go-deadlock: Move to golang-check.)
(define-public go-github-com-stretchr-testify
(package
diff --git a/gnu/packages/syncthing.scm b/gnu/packages/syncthing.scm
index 5e7e8f96db..de018065d2 100644
--- a/gnu/packages/syncthing.scm
+++ b/gnu/packages/syncthing.scm
@@ -403,30 +403,6 @@ higher-level API for doing so.")
(home-page "https://github.com/oschwald/maxminddb-golang")
(license isc)))
-(define-public go-github-com-sasha-s-go-deadlock
- (package
- (name "go-github-com-sasha-s-go-deadlock")
- (version "0.2.0")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/sasha-s/go-deadlock")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "13p7b7pakd9k1c2k0fs1hfim3c8mivz679977ai6zb01s4aw7gyg"))))
- (build-system go-build-system)
- (arguments
- `(#:import-path "github.com/sasha-s/go-deadlock"))
- (propagated-inputs
- (list go-github-com-petermattis-goid))
- (synopsis "Deadlock detection in go")
- (description "This package provides tools for detecting deadlocks at
-run-time in Go.")
- (home-page "https://github.com/sasha-s/go-deadlock")
- (license asl2.0)))
-
(define-public go-github-com-thejerf-suture
(package
(name "go-github-com-thejerf-suture")