summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2024-06-26 10:26:11 -0400
committerLeo Famulari <leo@famulari.name>2024-06-26 10:35:46 -0400
commit1b2e1396246edca1f743b2ba37e2e693659d349d (patch)
tree25ff8150762bda44b8ec5dadcbd856acf752ae79 /gnu/packages
parentf4d33ff2795adf3ec92efc41ea201c5535b15b61 (diff)
downloadguix-patches-1b2e1396246edca1f743b2ba37e2e693659d349d.tar
guix-patches-1b2e1396246edca1f743b2ba37e2e693659d349d.tar.gz
Revert "gnu: git: Update to 2.45.2."
This partially reverts commit 26c0ff98cf4302fc69539272d646c0ef28991991, removing some extraneous changes that were added by mistake. This is a followup to commit 26c0ff98cf4302fc69539272d646c0ef28991991 Change-Id: I907cfb98414ec8aeb1bbfc7b1b3d41fd36e8d309
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/linux.scm3
-rw-r--r--gnu/packages/version-control.scm6
2 files changed, 4 insertions, 5 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 93bc3b220a..9efd720225 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -10039,8 +10039,7 @@ headers.")
flex
(@ (gnu packages compression) zip)))
(inputs
- (list bash-minimal ;for wrap-program
- clang-15
+ (list clang-15
elfutils
luajit
libbpf
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index da02d0e4ea..0e73854fb1 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -242,14 +242,14 @@ Python 3.3 and later, rather than on Python 2.")
(define-public git
(package
(name "git")
- (version "2.45.2")
+ (version "2.45.1")
(source (origin
(method url-fetch)
(uri (string-append "mirror://kernel.org/software/scm/git/git-"
version ".tar.xz"))
(sha256
(base32
- "1nws1vjgj54sv32wxl1h3n1jkcpabqv7a605hhafsby0n5zfigsi"))))
+ "1gqj5xrlmzs4amrj7xgxx7qpqj8br8f6bk4bzcnf4yk2iq538kg6"))))
(build-system gnu-build-system)
(native-inputs
`(("native-perl" ,perl)
@@ -269,7 +269,7 @@ Python 3.3 and later, rather than on Python 2.")
version ".tar.xz"))
(sha256
(base32
- "1pqrp46kwbxycqld39027ph1cvkq9am156y3sswn6w2khsg30f09"))))
+ "1w6r2liifafsxydmc48p578z7z70ys0spm6qp5ygdd0l26mxf8p6"))))
;; For subtree documentation.
("asciidoc" ,asciidoc)
("docbook2x" ,docbook2x)