summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-06-26 23:02:10 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-06-27 00:34:28 +0100
commit0aad1bf8b189a0fe42ba489ad2dbfda3a99a4d77 (patch)
treecc8bb450d3b33bb84199de120c5ccd04432c4118 /gnu/packages
parent97e02a903e559ef588211ffd9241a7008d2d2f5e (diff)
downloadguix-patches-0aad1bf8b189a0fe42ba489ad2dbfda3a99a4d77.tar
guix-patches-0aad1bf8b189a0fe42ba489ad2dbfda3a99a4d77.tar.gz
gnu: go-github-com-audriusbutkevicius-pfilter: Move to golang-web.
* gnu/packages/syncthing.scm (go-github-com-audriusbutkevicius-pfilter): Move from here ... * gnu/packages/golang-web.scm: ... to here. Change-Id: Ie148e31dde805b79956553988431153159598acc
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/golang-web.scm24
-rw-r--r--gnu/packages/syncthing.scm23
2 files changed, 24 insertions, 23 deletions
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index bb0712e143..3ea81c7f06 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -190,6 +190,30 @@ result and details about the health status of each component.")
the parse trees produced by the html package.")
(license license:bsd-2)))
+(define-public go-github-com-audriusbutkevicius-pfilter
+ (package
+ (name "go-github-com-audriusbutkevicius-pfilter")
+ (version "0.0.5")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/AudriusButkevicius/pfilter")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0xzhwyd0w21bhvzl5pinn22hp0y6h44rh3s2ppql69rafc6zd3c6"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/AudriusButkevicius/pfilter"))
+ (home-page "https://github.com/AudriusButkevicius/pfilter")
+ (synopsis "Filter packets into multiple virtual connections")
+ (description
+ "Pfilter is a Go package for filtering packets into multiple virtual
+connections from a single physical connection.")
+ (license license:expat)))
+
(define-public go-github-com-aws-sdk
(package
(name "go-github-com-aws-sdk")
diff --git a/gnu/packages/syncthing.scm b/gnu/packages/syncthing.scm
index de71d887e7..4314cca93a 100644
--- a/gnu/packages/syncthing.scm
+++ b/gnu/packages/syncthing.scm
@@ -611,29 +611,6 @@ quoting, commenting, and escaping.")
(home-page "https://github.com/flynn-archive/go-shlex")
(license asl2.0))))
-(define-public go-github-com-audriusbutkevicius-pfilter
- (package
- (name "go-github-com-audriusbutkevicius-pfilter")
- (version "0.0.5")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/AudriusButkevicius/pfilter")
- (commit version)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0xzhwyd0w21bhvzl5pinn22hp0y6h44rh3s2ppql69rafc6zd3c6"))))
- (build-system go-build-system)
- (arguments
- '(#:import-path "github.com/AudriusButkevicius/pfilter"))
- (synopsis "Filter packets into multiple virtual connections")
- (description "Pfilter is a Go package for filtering packets into multiple
-virtual connections from a single physical connection.")
- (home-page "https://github.com/AudriusButkevicius/pfilter")
- (license expat)))
-
(define-public go-github-com-ccding-go-stun
(let ((commit "be486d185f3dfcb2dbf8429332da50a0da7f95a6")
(revision "2"))