summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorJosselin Poiret <dev@jpoiret.xyz>2023-04-15 16:08:18 +0200
committerAndreas Enge <andreas@enge.fr>2023-04-15 22:28:58 +0200
commitdf6848565aef4371f9ac4749145a59f9a41a76f3 (patch)
treeca97617aa48b7f48c413e3edb659cbed72e243cd /gnu/packages
parentd16538c935f6bd49dec032db2e484b2652a404fd (diff)
downloadguix-patches-df6848565aef4371f9ac4749145a59f9a41a76f3.tar
guix-patches-df6848565aef4371f9ac4749145a59f9a41a76f3.tar.gz
gnu: python-pytest: Fix failing test_raising_repr.
* gnu/packages/patches/pytest-fix-unstrable-exception-test.patch: Add new patch from upstream. * gnu/packages/check.scm (python-pytest): Use it. * gnu/local.mk (dist_patch_DATA): Register it. Signed-off-by: Andreas Enge <andreas@enge.fr>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/check.scm3
-rw-r--r--gnu/packages/patches/pytest-fix-unstrable-exception-test.patch34
2 files changed, 36 insertions, 1 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 14e8607154..cb38ea8538 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -1268,7 +1268,8 @@ standard library.")
(uri (pypi-uri "pytest" version))
(sha256
(base32
- "0f8c31v5r2kgjixvy267n0nhc4xsy65g3n9lz1i1377z5pn5ydjg"))))
+ "0f8c31v5r2kgjixvy267n0nhc4xsy65g3n9lz1i1377z5pn5ydjg"))
+ (patches (search-patches "pytest-fix-unstrable-exception-test.patch"))))
(build-system python-build-system)
(arguments
(list
diff --git a/gnu/packages/patches/pytest-fix-unstrable-exception-test.patch b/gnu/packages/patches/pytest-fix-unstrable-exception-test.patch
new file mode 100644
index 0000000000..4d77786b77
--- /dev/null
+++ b/gnu/packages/patches/pytest-fix-unstrable-exception-test.patch
@@ -0,0 +1,34 @@
+From b55e264a675f7621b8351e227b93742f19e01c7d Mon Sep 17 00:00:00 2001
+From: Daniel Valenzuela <dsvalenzuela@uc.cl>
+Date: Wed, 9 Nov 2022 19:43:10 -0300
+Subject: [PATCH] Fix test_raising_repr test
+
+Closes #10473
+
+Python <3.11 versions depend on `exceptiongroup>=1.0.0rc8`, and they released version `1.0.1`
+6 days ago (2022/11/03) that as a side-effect changed the output of exceptions.
+---
+ testing/test_assertion.py | 10 +---------
+ 1 file changed, 1 insertion(+), 9 deletions(-)
+
+diff --git a/testing/test_assertion.py b/testing/test_assertion.py
+index d8844f2e41..7574592210 100644
+--- a/testing/test_assertion.py
++++ b/testing/test_assertion.py
+@@ -1664,15 +1664,7 @@ def test_raising_repr():
+ """
+ )
+ result = pytester.runpytest()
+- if sys.version_info >= (3, 11):
+- # python 3.11 has native support for un-str-able exceptions
+- result.stdout.fnmatch_lines(
+- ["E AssertionError: <exception str() failed>"]
+- )
+- else:
+- result.stdout.fnmatch_lines(
+- ["E AssertionError: <unprintable AssertionError object>"]
+- )
++ result.stdout.fnmatch_lines(["E AssertionError: <exception str() failed>"])
+
+
+ def test_issue_1944(pytester: Pytester) -> None: