summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2023-02-12 01:00:02 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2023-02-12 01:00:00 +0100
commit3286a38c42d8c88a6ac1e869d12d8e77357246e8 (patch)
tree2c9c393710f404d01bcd0560b2261d77fa4b1180 /gnu/packages
parentb6fea89ad6571c07158abd93847a27cb2478641a (diff)
downloadguix-patches-3286a38c42d8c88a6ac1e869d12d8e77357246e8.tar
guix-patches-3286a38c42d8c88a6ac1e869d12d8e77357246e8.tar.gz
gnu: nmap: Remove input labels.
* gnu/packages/admin.scm (nmap)[inputs]: Move to conventional location, remove input labels, and order sortabetically.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/admin.scm20
1 files changed, 8 insertions, 12 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 555932b197..3bf03aeec6 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -3332,18 +3332,7 @@ rules is done with the @code{auditctl} utility.")
;; Remove pre-compiled binares.
"mswin32"))))))
(build-system gnu-build-system)
- (inputs
- `(("openssl" ,openssl-3.0)
- ("libpcap" ,libpcap)
- ("pcre" ,pcre)
- ("lua" ,lua)
- ("zlib" ,zlib) ;for NSE compression support
-
- ;; For 'ndiff'.
- ("python" ,python-2)))
-
- ;; TODO Add zenmap output.
- (outputs '("out" "ndiff"))
+ (outputs '("out" "ndiff")) ; TODO Add zenmap output
(arguments
`(#:configure-flags '("--without-zenmap")
#:phases
@@ -3386,6 +3375,13 @@ rules is done with the @code{auditctl} utility.")
"check-dns")))))
;; Nmap can't cope with out-of-source building.
#:out-of-source? #f))
+ (inputs
+ (list libpcap
+ lua
+ openssl-3.0
+ pcre
+ zlib ; for NSE compression
+ python-2)) ; for ndiff
(home-page "https://nmap.org/")
(synopsis "Network discovery and security auditing tool")
(description