summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorjgart <jgart@dismail.de>2023-02-17 19:14:26 +0100
committerGuillaume Le Vaillant <glv@posteo.net>2023-02-17 19:18:49 +0100
commit2921394c25883a91a541c6b3ba6a75ecfe97a01f (patch)
treea5e15e8fb5af0436384e395e17be887fc88c59a7 /gnu/packages
parente93171b26327d20766dba2d1e51b2353a6ca9c28 (diff)
downloadguix-patches-2921394c25883a91a541c6b3ba6a75ecfe97a01f.tar
guix-patches-2921394c25883a91a541c6b3ba6a75ecfe97a01f.tar.gz
gnu: Add cl-lisp-stat.
* gnu/packages/lisp-xyz.scm (cl-lisp-stat, sbcl-lisp-stat): New variables. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/lisp-xyz.scm44
1 files changed, 44 insertions, 0 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 14f5b56da2..bb5855c7b7 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -27161,6 +27161,50 @@ in files using data frames.")
;; (define-public ecl-dfio
;; (sbcl-package->ecl-package sbcl-dfio))
+(define-public sbcl-lisp-stat
+ (let ((commit "357a0d2b5f68a5ff925776235c2b7455e12b78ba")
+ (revision "0"))
+ (package
+ (name "sbcl-lisp-stat")
+ (version (git-version "1.2.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Lisp-Stat/lisp-stat")
+ (commit commit)))
+ (file-name (git-file-name "cl-lisp-stat" version))
+ (sha256
+ (base32 "0qwlxrbwj884mr67sf6aj0zwrndv33aiiid4bqrkji41kjhqfcz5"))))
+ (build-system asdf-build-system/sbcl)
+ ;; https://github.com/Lisp-Stat/lisp-stat/issues/22
+ (arguments (list #:tests? #f))
+ (native-inputs (list sbcl-parachute))
+ (inputs
+ (list sbcl-alexandria
+ sbcl-alexandria-plus
+ sbcl-array-operations
+ sbcl-conduit-packages
+ sbcl-data-frame
+ sbcl-dexador
+ sbcl-dfio
+ sbcl-distributions
+ sbcl-numerical-utilities
+ sbcl-select
+ sbcl-statistics))
+ (home-page "https://lisp-stat.github.io/lisp-stat/")
+ (synopsis "Statistical Computing in Common Lisp")
+ (description "This package provides a statistical computing
+environment for Common Lisp.")
+ (license license:ms-pl))))
+
+(define-public cl-lisp-stat
+ (sbcl-package->cl-source-package sbcl-lisp-stat))
+
+;; This depends on ecl-data-frame and ecl-dfio, which don't work yet.
+;; (define-public ecl-lisp-stat
+;; (sbcl-package->ecl-package sbcl-lisp-stat))
+
;;;
;;; Avoid adding new packages to the end of this file. To reduce the chances
;;; of a merge conflict, place them above by existing packages with similar