summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorFelix Gruber <felgru@posteo.net>2024-06-09 09:35:07 +0000
committerAndreas Enge <andreas@enge.fr>2024-07-07 12:09:00 +0200
commitc86a07bacc2469e7a00fbc66cfe4f322e4bafb06 (patch)
treec294292acfaf06652d638f162a173deb8895609d /gnu/packages
parentb141f45642fec0446970f3ba0a307086b4cb39b7 (diff)
downloadguix-patches-c86a07bacc2469e7a00fbc66cfe4f322e4bafb06.tar
guix-patches-c86a07bacc2469e7a00fbc66cfe4f322e4bafb06.tar.gz
gnu: python-pdfminer-six: Update to 20231228.
* gnu/packages/python-xyz.scm (python-pdfminer-six): Update to 20231228. [build-system]: Use pyproject-build-system. [arguments]: Convert to gexp and remove custom 'check phase. [propagated-inputs]: Remove python-chardet and python-sortedcontainers. Add python-charset-normalizer. [native-inputs]: Remove python-nose and python-tox. Add python-pytest. Change-Id: I9913385a681b32afde930e32e7379db91357177b Signed-off-by: Andreas Enge <andreas@enge.fr>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python-xyz.scm26
1 files changed, 11 insertions, 15 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 36f75b4b40..1c432e9b65 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -20017,7 +20017,7 @@ encoding algorithms to do fuzzy string matching.")
(define-public python-pdfminer-six
(package
(name "python-pdfminer-six")
- (version "20201018")
+ (version "20231228")
;; There are no tests in the PyPI tarball.
(source
(origin
@@ -20027,23 +20027,19 @@ encoding algorithms to do fuzzy string matching.")
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "1a2fxxnnjqbx344znpvx7cnv1881dk6585ibw01inhfq3w6yj2lr"))))
- (build-system python-build-system)
+ (base32 "1anyr0gm7amwls8qifflql1viz5rq6q95lfwcg43v3180h4w8wrd"))))
+ (build-system pyproject-build-system)
(arguments
- `(#:phases
- (modify-phases %standard-phases
- ;; Tests write to the source tree.
- (add-after 'unpack 'make-git-checkout-writable
- (lambda _
- (for-each make-file-writable (find-files "."))
- #t))
- (replace 'check
- (lambda _
- (invoke "make" "test"))))))
+ (list #:phases
+ #~(modify-phases %standard-phases
+ ;; Tests write to the source tree.
+ (add-after 'unpack 'make-git-checkout-writable
+ (lambda _
+ (for-each make-file-writable (find-files ".")))))))
(propagated-inputs
- (list python-chardet python-cryptography python-sortedcontainers))
+ (list python-charset-normalizer python-cryptography))
(native-inputs
- (list python-nose python-tox))
+ (list python-pytest))
(home-page "https://github.com/pdfminer/pdfminer.six")
(synopsis "PDF parser and analyzer")
(description "@code{pdfminer.six} is a community maintained fork of