summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorTaylan Kammer <taylan.kammer@gmail.com>2024-06-07 06:44:55 -0700
committerGuix Patches Tester <>2024-07-07 15:42:11 +0200
commit9bf4fdf9d0e5d01db0533d14697e6fab069a7729 (patch)
tree96acd95660b7bf7d70b3c6ec8a883cb854c5bd2f /gnu/packages
parentc86a07bacc2469e7a00fbc66cfe4f322e4bafb06 (diff)
downloadguix-patches-9bf4fdf9d0e5d01db0533d14697e6fab069a7729.tar
guix-patches-9bf4fdf9d0e5d01db0533d14697e6fab069a7729.tar.gz
gnu: guile-bytestructures: Update to 2.0.1.
* gnu/packages/guile.scm (guile-bytestructures): Update to 2.0.1. Although the major version number is increased due to a small API-breaking change, all packages that depend on guile-bytestructures still build fine and pass their test suite if they have one, so it should not be necessary to create a bytestructures-2.0 package. The breaking change is that bs:pointer would previously implicitly dereference the pointer when any index other than '* was provided, whereas in this version the dereference must be explicit, and can be '* or an integer that represents an offset from the pointer address a la *(ptr + i) in C.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/guile.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
index e8705dc7d2..0bbd4a12ad 100644
--- a/gnu/packages/guile.scm
+++ b/gnu/packages/guile.scm
@@ -786,7 +786,7 @@ Guile's foreign function interface.")
(define-public guile-bytestructures
(package
(name "guile-bytestructures")
- (version "1.0.10")
+ (version "2.0.1")
(home-page "https://github.com/TaylanUB/scheme-bytestructures")
(source (origin
(method git-fetch)
@@ -796,7 +796,7 @@ Guile's foreign function interface.")
(file-name (git-file-name name version))
(sha256
(base32
- "14k50jln32kkxv41hvsdgjkkfj6xlv06vc1caz01qkgk1fzh72nk"))))
+ "1gnh3p2042cch1nkapl0p4pv20q7qs8cxvvbp7a5h1dwqbrkdyss"))))
(build-system gnu-build-system)
(arguments
`(#:make-flags '("GUILE_AUTO_COMPILE=0") ;to prevent guild warnings