summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2024-07-06 14:10:03 -0300
committerVinicius Monego <monego@posteo.net>2024-07-06 23:05:52 -0300
commit4b3b80f57c9c44380c2754a89cfcf6a8d74ed269 (patch)
tree239485eaeb50bffde39825ee168e012afd5ac6b4 /gnu/packages
parent426739bd9dd2e504d140eb02a68c1898c02ffd4b (diff)
downloadguix-patches-4b3b80f57c9c44380c2754a89cfcf6a8d74ed269.tar
guix-patches-4b3b80f57c9c44380c2754a89cfcf6a8d74ed269.tar.gz
gnu: xonsh: Move to pyproject-build-system.
* gnu/packages/shells.scm (xonsh)[build-system]: Move to pyproject-build-system. Change-Id: I033a05b2eb94f15510ff7c3753768aec013dd11a
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/shells.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/shells.scm b/gnu/packages/shells.scm
index e916ab1653..ad8bb3f182 100644
--- a/gnu/packages/shells.scm
+++ b/gnu/packages/shells.scm
@@ -80,6 +80,7 @@
#:use-module (guix build-system cmake)
#:use-module (guix build-system gnu)
#:use-module (guix build-system meson)
+ #:use-module (guix build-system pyproject)
#:use-module (guix build-system python)
#:use-module (guix build-system trivial)
#:use-module (guix download)
@@ -573,7 +574,7 @@ ksh, and tcsh.")
(format #f "from ~a import" module))
(("from xonsh\\.ply import") "import"))
#t))))
- (build-system python-build-system)
+ (build-system pyproject-build-system)
(arguments
(list ;; TODO Try running run the test suite.
;; See 'requirements-tests.txt' in the source distribution for more