summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2016-08-11 07:56:13 -0500
committerEric Bavier <bavier@member.fsf.org>2016-08-13 11:02:51 -0500
commitd85b398bb77f6b9fddea1ee22181a6fd99163467 (patch)
tree0ef119624dfcc5d1dd0792e233bf9d222c0dc78b /gnu/packages
parentb718bef08e807f21a8c080549e3c971183c5222c (diff)
downloadguix-patches-d85b398bb77f6b9fddea1ee22181a6fd99163467.tar
guix-patches-d85b398bb77f6b9fddea1ee22181a6fd99163467.tar.gz
gnu: Add Aircrack-ng.
* gnu/packages/networking.scm (aircrack-ng): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/networking.scm55
1 files changed, 55 insertions, 0 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 77207c0e8a..1275a41738 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -7,6 +7,7 @@
;;; Copyright © 2016 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2016 John Darrington <jmd@gnu.org>
;;; Copyright © 2016 Nicolas Goaziou <mail@nicolasgoaziou.fr>
+;;; Copyright © 2016 Eric Bavier <bavier@member.fsf.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -38,6 +39,7 @@
#:use-module (gnu packages bison)
#:use-module (gnu packages check)
#:use-module (gnu packages compression)
+ #:use-module (gnu packages databases)
#:use-module (gnu packages flex)
#:use-module (gnu packages gettext)
#:use-module (gnu packages gnupg)
@@ -46,6 +48,7 @@
#:use-module (gnu packages lua)
#:use-module (gnu packages mit-krb5)
#:use-module (gnu packages ncurses)
+ #:use-module (gnu packages pcre)
#:use-module (gnu packages perl)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages python)
@@ -415,6 +418,58 @@ by firewalls or when you want to monitor the response time of the actual web
application stack itself.")
(license license:gpl2))) ; with permission to link with OpenSSL
+(define-public aircrack-ng
+ (package
+ (name "aircrack-ng")
+ (version "1.2-rc4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "http://download.aircrack-ng.org/aircrack-ng-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0dpzx9kddxpgzmgvdpl3rxn0jdaqhm5wxxndp1xd7d75mmmc2fnr"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (inputs
+ `(("libgcrypt" ,libgcrypt)
+ ("libnl" ,libnl)
+ ("ethtool" ,ethtool)
+ ("pcre" ,pcre)
+ ("sqlite" ,sqlite)
+ ("zlib" ,zlib)))
+ (arguments
+ `(#:make-flags `("sqlite=true"
+ "gcrypt=true"
+ "libnl=true"
+ "pcre=true"
+ "experimental=true" ;build wesside-ng, etc.
+ "AVX2FLAG=N" "AVX1FLAG=N" "SSEFLAG=Y"
+ ,(string-append "prefix=" %output))
+ #:phases (modify-phases %standard-phases
+ (delete 'configure) ;no configure phase
+ (add-after 'build 'absolutize-tools
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((ethtool (string-append (assoc-ref inputs "ethtool")
+ "/sbin/ethtool")))
+ (substitute* "scripts/airmon-ng"
+ (("\\[ ! -x \"\\$\\(command -v ethtool 2>&1)\" \\]")
+ (string-append "! " ethtool " --version "
+ ">/dev/null 2>&1"))
+ (("\\$\\(ethtool")
+ (string-append "$(" ethtool)))
+ #t))))))
+ (home-page "http://www.aircrack-ng.org")
+ (synopsis "Assess WiFi network security")
+ (description
+ "Aircrack-ng is a complete suite of tools to assess WiFi network
+security. It focuses on different areas of WiFi security: monitoring,
+attacking, testing, and cracking. All tools are command-line driven, which
+allows for heavy scripting.")
+ (license (list license:gpl2+ license:bsd-3))))
+
(define-public perl-net-dns
(package
(name "perl-net-dns")