summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-02-07 17:05:23 +0100
committerMarius Bakke <mbakke@fastmail.com>2018-02-07 17:05:23 +0100
commit53f826cd0f429864d46fc3bf6305c14356d0b2ad (patch)
tree2f39791a976b194f3891a6b8048fb94b9160fc5a /gnu/packages
parentb7049b2e23a514a1d9c131af484e808ee0ee4226 (diff)
downloadguix-patches-53f826cd0f429864d46fc3bf6305c14356d0b2ad.tar
guix-patches-53f826cd0f429864d46fc3bf6305c14356d0b2ad.tar.gz
gnu: python2-tqdm: Work around missing flake8 propagation.
* gnu/packages/python.scm (python-tqdm)[properties]: Declare python2 variant. (python2-tqdm): Use STRIP-PYTHON2-VARIANT. [native-inputs]: Add PYTHON-ENUM34.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python.scm12
1 files changed, 10 insertions, 2 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 6013c31acb..40c6077951 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -11929,10 +11929,18 @@ ignoring formatting changes.")
"Make loops show a progress bar on the console by just wrapping any
iterable with @code{|tqdm(iterable)|}. Offers many options to define
design and layout.")
- (license (list license:mpl2.0 license:expat))))
+ (license (list license:mpl2.0 license:expat))
+ (properties `((python2-variant . ,(delay python2-tqdm))))))
(define-public python2-tqdm
- (package-with-python2 python-tqdm))
+ (let ((tqdm (package-with-python2
+ (strip-python2-variant python-tqdm))))
+ (package
+ (inherit tqdm)
+ (native-inputs
+ ;; FIXME: This should be propagated from python2-flake8 instead.
+ `(("python2-enum34" ,python2-enum34)
+ ,@(package-native-inputs tqdm))))))
(define-public python-pkginfo
(package