summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-04-29 17:35:57 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-31 14:52:32 -0400
commite3205452db72a25eb130a9b1a5db151ecfbdc416 (patch)
tree59ecfce6e41308e7efd2685fd0809f30868ebfc3 /gnu/packages
parenta240fef7076677858ff41d3abf4c8d7830108427 (diff)
downloadguix-patches-e3205452db72a25eb130a9b1a5db151ecfbdc416.tar
guix-patches-e3205452db72a25eb130a9b1a5db151ecfbdc416.tar.gz
gnu: Remove gtklick.
* gnu/packages/music.scm (gtklick): Delete variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/music.scm46
1 files changed, 0 insertions, 46 deletions
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 1d07993416..dc34194905 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -1274,52 +1274,6 @@ standalone program which is able to download cover art, lyrics, photos,
biographies, reviews and more.")
(license license:lgpl3+)))
-(define-public gtklick
- (package
- (name "gtklick")
- (version "0.6.4")
- (source (origin
- (method url-fetch)
- (uri (string-append "http://das.nasophon.de/download/gtklick-"
- version ".tar.gz"))
- (sha256
- (base32
- "0dq1km6njnzsqdqyf6wzir9g733z0mc9vmxfg2383k3c2a2di6bp"))))
- (build-system python-build-system)
- (arguments
- `(#:tests? #f ; no tests
- #:python ,python-2
- #:phases
- (modify-phases %standard-phases
- (add-before 'build 'add-sitedirs
- ;; .pth files are not automatically interpreted unless the
- ;; directories containing them are added as "sites". The directories
- ;; are then added to those in the PYTHONPATH. This is required for
- ;; the operation of pygtk.
- (lambda _
- (substitute* "gtklick/gtklick.py"
- (("import pygtk")
- "import pygtk, site, sys
-for path in [path for path in sys.path if 'site-packages' in path]: site.addsitedir(path)"))))
- (add-after 'unpack 'inject-store-path-to-klick
- (lambda* (#:key inputs #:allow-other-keys)
- (substitute* "gtklick/klick_backend.py"
- (("KLICK_PATH = 'klick'")
- (string-append "KLICK_PATH = '"
- (assoc-ref inputs "klick")
- "/bin/klick'")))
- #t)))))
- (inputs
- (list klick python2-pyliblo python2-pygtk))
- (native-inputs
- `(("gettext" ,gettext-minimal)))
- (home-page "http://das.nasophon.de/gtklick/")
- (synopsis "Simple metronome with an easy-to-use graphical interface")
- (description
- "Gtklick is a simple metronome with an easy-to-use graphical user
-interface. It is implemented as a frontend to @code{klick}.")
- (license license:gpl2+)))
-
(define-public lingot
(package
(name "lingot")