summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMathieu Othacehe <m.othacehe@gmail.com>2019-09-27 10:46:06 +0200
committerMathieu Othacehe <m.othacehe@gmail.com>2019-09-27 10:48:54 +0200
commit772ca8e4f62d5b74286e39652b33afb817e17ca2 (patch)
treed040bf12470922b718b84ee320368fb907866015 /gnu/packages
parent308eb5c11a885768f81fb6136fd4d30b4639fe04 (diff)
downloadguix-patches-772ca8e4f62d5b74286e39652b33afb817e17ca2.tar
guix-patches-772ca8e4f62d5b74286e39652b33afb817e17ca2.tar.gz
gnu: supercollider: Fix build and update to 3.10.3.
* gnu/packages/patches/supercollider-boost-1.70-build-fix.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/audio.scm (supercollider): Update to 3.10.3 and apply the previous patch to fix build with boost-1.70. Remove outdated 'fix-build-with-boost-1.68 phase.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/audio.scm13
-rw-r--r--gnu/packages/patches/supercollider-boost-1.70-build-fix.patch28
2 files changed, 33 insertions, 8 deletions
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 36fc434160..f1a45bc1ca 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -22,6 +22,7 @@
;;; Copyright © 2019 Leo Famulari <leo@famulari.name>
;;; Copyright © 2019 Rutger Helling <rhelling@mykolab.com>
;;; Copyright © 2019 Arun Isaac <arunisaac@systemreboot.net>
+;;; Copyright © 2019 Mathieu Othacehe <m.othacehe@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -2177,16 +2178,18 @@ background file post-processing.")
(define-public supercollider
(package
(name "supercollider")
- (version "3.10.2")
+ (version "3.10.3")
(source (origin
(method url-fetch)
(uri (string-append
"https://github.com/supercollider/supercollider"
"/releases/download/Version-" version
"/SuperCollider-" version "-Source-linux.tar.bz2"))
+ (patches
+ (search-patches "supercollider-boost-1.70-build-fix.patch"))
(sha256
(base32
- "0ynz1ydcpsd5h57h1n4a7avm6p1cif5a8rkmz4qpr46pr8z9p6iq"))))
+ "0srm6wbazidkrd4ckjy4ypyhkdwcnx2i7k9msjyngalh0mrc9zz1"))))
(build-system cmake-build-system)
(arguments
`(#:configure-flags '("-DSYSTEM_BOOST=on" "-DSYSTEM_YAMLCPP=on"
@@ -2198,12 +2201,6 @@ background file post-processing.")
(ice-9 ftw))
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'fix-build-with-boost-1.68
- (lambda _
- (substitute* "server/supernova/utilities/time_tag.hpp"
- (("(time_duration offset = .+ microseconds\\().*" _ m)
- (string-append m "static_cast<long>(get_nanoseconds()/1000));\n")))
- #t))
(add-after 'unpack 'rm-bundled-libs
(lambda _
;; The build system doesn't allow us to unbundle the following
diff --git a/gnu/packages/patches/supercollider-boost-1.70-build-fix.patch b/gnu/packages/patches/supercollider-boost-1.70-build-fix.patch
new file mode 100644
index 0000000000..073044fccb
--- /dev/null
+++ b/gnu/packages/patches/supercollider-boost-1.70-build-fix.patch
@@ -0,0 +1,28 @@
+Patches taken from https://gitweb.gentoo.org/repo/gentoo.git/tree/media-sound/supercollider/files/supercollider-3.10.2-boost-1.70.patch?id=a420618dc766bba0654dbe0ef67008fdc5e901c6 to fix supercollider build with boost 1.70.
+
+diff --git a/server/supernova/sc/sc_osc_handler.cpp b/server/supernova/sc/sc_osc_handler.cpp
+index 5116a1be87..96e937ec25 100644
+--- a/server/supernova/sc/sc_osc_handler.cpp
++++ b/server/supernova/sc/sc_osc_handler.cpp
+@@ -728,7 +728,8 @@ void sc_osc_handler::tcp_connection::handle_message() {
+
+
+ void sc_osc_handler::start_tcp_accept(void) {
+- tcp_connection::pointer new_connection = tcp_connection::create(tcp_acceptor_.get_io_service());
++ tcp_connection::pointer new_connection =
++ tcp_connection::create((boost::asio::io_context&)tcp_acceptor_.get_executor().context());
+
+ tcp_acceptor_.async_accept(
+ new_connection->socket(),
+diff --git a/server/supernova/utilities/utils.hpp b/server/supernova/utilities/utils.hpp
+index 35b8ab5ad..a7c191f2d 100644
+--- a/server/supernova/utilities/utils.hpp
++++ b/server/supernova/utilities/utils.hpp
+@@ -23,6 +23,7 @@
+
+ #include <type_traits>
+
++#include <boost/checked_delete.hpp>
+ #include <boost/intrusive_ptr.hpp>
+ #include <boost/noncopyable.hpp>
+ #include <boost/detail/atomic_count.hpp>