summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorZheng junjie <873216071@qq.com>2021-06-11 20:53:11 +0800
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-06-13 19:14:08 +0200
commit35459b600ebfe2793a670e042ed9ee249dbfbdd0 (patch)
treefdccd350012e09e4b62c9b79c83491ecfc8615df /gnu/packages
parent83ed670443ff5fff4e9733ca8523de8ee4c80644 (diff)
downloadguix-patches-35459b600ebfe2793a670e042ed9ee249dbfbdd0.tar
guix-patches-35459b600ebfe2793a670e042ed9ee249dbfbdd0.tar.gz
gnu: Add rust-fsevent-sys-3.
* gnu/packages/crates-io.scm (rust-fsevent-sys-3): New variable. (rust-fsevent-sys-2): inherit from above. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/crates-io.scm33
1 files changed, 26 insertions, 7 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 937a5017cd..55d8a4857d 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -16228,8 +16228,33 @@ process and much more.")
for file changes notifications")
(license license:expat)))
+(define-public rust-fsevent-sys-3
+ (package
+ (name "rust-fsevent-sys")
+ (version "3.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "fsevent-sys" version))
+ (file-name
+ (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1mav57d1zcp4x17h0wprcr188d8yvxfz1c0f1z0p31q52xl5wvya"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:skip-build? #t
+ #:cargo-inputs
+ (("rust-libc" ,rust-libc-0.2))))
+ (home-page "https://github.com/octplane/fsevent-rust/tree/master/fsevent-sys")
+ (synopsis "Rust bindings to the fsevent macOS API")
+ (description "This package provides Rust bindings to the @code{fsevent}
+macOS API for file changes notifications")
+ (license license:expat)))
+
(define-public rust-fsevent-sys-2
(package
+ (inherit rust-fsevent-sys-3)
(name "rust-fsevent-sys")
(version "2.0.1")
(source
@@ -16241,15 +16266,9 @@ for file changes notifications")
(sha256
(base32
"18246vxk7rqn52m0sfrhivxq802i34p2wqqx5zsa0pamjj5086zl"))))
- (build-system cargo-build-system)
(arguments
`(#:skip-build? #t ; only available on macOS
- #:cargo-inputs (("rust-libc" ,rust-libc-0.2))))
- (home-page "https://github.com/octplane/fsevent-rust/tree/master/fsevent-sys")
- (synopsis "Rust bindings to the fsevent macOS API")
- (description "This package provides Rust bindings to the @code{fsevent}
-macOS API for file changes notifications")
- (license license:expat)))
+ #:cargo-inputs (("rust-libc" ,rust-libc-0.2))))))
(define-public rust-fst-0.4
(package