summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-12-12 01:03:06 +0100
committerMarius Bakke <mbakke@fastmail.com>2017-12-12 01:08:06 +0100
commitf419fe4ddb55e2c78243ba4c66a3483e21662ee0 (patch)
tree76c1878330bf60eb89021bad5d6a0f92f6abfd70 /gnu/packages
parent7f7419b56f9cc4e4e2bbbd0e8268c8d762887687 (diff)
downloadguix-patches-f419fe4ddb55e2c78243ba4c66a3483e21662ee0.tar
guix-patches-f419fe4ddb55e2c78243ba4c66a3483e21662ee0.tar.gz
gnu: Remove ffmpeg@3.3.
The reason this was required was because of a regression in ffmpeg 3.4; see <https://trac.ffmpeg.org/ticket/6775>. * gnu/packages/gstreamer.scm (gst-libav)[inputs]: Change FFMPEG-3.3 to FFMPEG. * gnu/packages/video.scm (ffmpeg-3.3): Remove variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/gstreamer.scm2
-rw-r--r--gnu/packages/video.scm13
2 files changed, 1 insertions, 14 deletions
diff --git a/gnu/packages/gstreamer.scm b/gnu/packages/gstreamer.scm
index 33f05d69f7..5fad28952b 100644
--- a/gnu/packages/gstreamer.scm
+++ b/gnu/packages/gstreamer.scm
@@ -402,7 +402,7 @@ distribution problems in some jurisdictions, e.g. due to patent threats.")
("python" ,python)))
(inputs
`(("gst-plugins-base" ,gst-plugins-base)
- ("ffmpeg" ,ffmpeg-3.3)
+ ("ffmpeg" ,ffmpeg)
("orc" ,orc)
("zlib" ,zlib)))
(home-page "http://gstreamer.freedesktop.org/")
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 523682460b..0bd1be6e62 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -762,19 +762,6 @@ convert and stream audio and video. It includes the libavcodec
audio/video codec library.")
(license license:gpl2+)))
-;; XXX: Remove this when gst-libav and qtox supports 3.4.
-(define-public ffmpeg-3.3
- (package
- (inherit ffmpeg)
- (version "3.3.5")
- (source (origin
- (method url-fetch)
- (uri (string-append "https://ffmpeg.org/releases/ffmpeg-"
- version ".tar.xz"))
- (sha256
- (base32
- "00nq8ng2p16yb48acargaz1hlp9kq24vfwvkqjlslz4a7864k4x8"))))))
-
(define-public ffmpeg-2.8
(package
(inherit ffmpeg)