summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2020-12-20 19:39:49 +0100
committerMarius Bakke <marius@gnu.org>2020-12-20 23:40:45 +0100
commit00f34c00577f7c8fb8d79b7fb6112ad10f9e9e53 (patch)
treeec430685c3331061910ea8a2c4b79cc893d41ce6 /gnu/packages
parent3668405daa7291694114276165d1e5c5366ff9d7 (diff)
downloadguix-patches-00f34c00577f7c8fb8d79b7fb6112ad10f9e9e53.tar
guix-patches-00f34c00577f7c8fb8d79b7fb6112ad10f9e9e53.tar.gz
gnu: texlive-latex-hyperref: Don't use unstable tarball.
* gnu/packages/tex.scm (texlive-latex-hyperref)[source]: Switch to GIT-FETCH.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/tex.scm11
1 files changed, 6 insertions, 5 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 1002fcdda9..4e7196e4f7 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -2791,13 +2791,14 @@ tables.")
;; The sources in the TeX Live SVN repository do not contain hluatex.dtx,
;; so we fetch the release from GitHub.
(source (origin
- (method url-fetch)
- (uri (string-append "https://github.com/ho-tex/hyperref/"
- "archive/release-" version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ho-tex/hyperref")
+ (commit (string-append "release-" version))))
+ (file-name (git-file-name name version))
(sha256
(base32
- "1d3rmjgzh0025a1dza55zb6nzzlgd1y9snwx45wq1c1vf42m79h2"))))
+ "186x6qmzyr51sfi9zkpgf5js8mn0qfryqdvwbfg58pyilw1l3vkm"))))
(build-system texlive-build-system)
(arguments '(#:tex-directory "latex/hyperref"))
(propagated-inputs