summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2018-09-02 16:56:05 +0300
committerEfraim Flashner <efraim@flashner.co.il>2018-09-03 08:32:33 +0300
commit647465ace9fdb474c924585c18e4056fe12a6052 (patch)
treeefb1d979614fe9f6440beb54ffc66d947888f855 /gnu/packages
parent391097782311c82c04b171db7373a0bbfc1d8653 (diff)
downloadguix-patches-647465ace9fdb474c924585c18e4056fe12a6052.tar
guix-patches-647465ace9fdb474c924585c18e4056fe12a6052.tar.gz
gnu: jellyfish: Update to 2.2.10.
* gnu/packages/bioinformatics.scm (jellyfish): Update to 2.2.10. [supported-systems]: Add aarch64-linux, mips64el-linux.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/bioinformatics.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 22a00894c2..f60fc4c84c 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -3602,7 +3602,7 @@ experiments and provide highly stable thresholds based on reproducibility.")
(define-public jellyfish
(package
(name "jellyfish")
- (version "2.2.7")
+ (version "2.2.10")
(source (origin
(method url-fetch)
(uri (string-append "https://github.com/gmarcais/Jellyfish/"
@@ -3610,7 +3610,7 @@ experiments and provide highly stable thresholds based on reproducibility.")
"/jellyfish-" version ".tar.gz"))
(sha256
(base32
- "1a1iwq9pq54k2m9ypvwl5s0bqfl64gwh9dx5af9i382ajas2016q"))))
+ "1k4pc3fvv6w1km2yph4m5sd78fbxp21d6xyzgmy0gjihzc6mb249"))))
(build-system gnu-build-system)
(outputs '("out" ;for library
"ruby" ;for Ruby bindings
@@ -3647,8 +3647,8 @@ DNA sequences. It outputs its k-mer counts in a binary format, which can be
translated into a human-readable text format using the @code{jellyfish dump}
command, or queried for specific k-mers with @code{jellyfish query}.")
(home-page "http://www.genome.umd.edu/jellyfish.html")
- ;; From their website: JELLYFISH runs on 64-bit Intel-compatible processors
- (supported-systems '("x86_64-linux"))
+ ;; JELLYFISH seems to be 64-bit only.
+ (supported-systems '("x86_64-linux" "aarch64-linux" "mips64el-linux"))
;; The combined work is published under the GPLv3 or later. Individual
;; files such as lib/jsoncpp.cpp are released under the Expat license.
(license (list license:gpl3+ license:expat))))