summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2019-11-14 22:38:10 +0100
committerLudovic Courtès <ludo@gnu.org>2019-11-14 22:38:10 +0100
commit2387e2f2d1839b79f13ddd832f9a008bb220eed6 (patch)
tree4122210758706f534e2da4722627fc52438a45eb /gnu/packages
parent4554d6b77e0f306a3dc33a8c1f68c9a302967a08 (diff)
downloadguix-patches-2387e2f2d1839b79f13ddd832f9a008bb220eed6.tar
guix-patches-2387e2f2d1839b79f13ddd832f9a008bb220eed6.tar.gz
gnu: aspell: Update to 0.60.8.
* gnu/packages/aspell.scm (aspell): Update to 0.60.8. [source]: Remove "aspell-gcc-compat.patch". * gnu/packages/patches/aspell-gcc-compat.patch: Remove. * gnu/local.mk (dist_patch_DATA): Remove it.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/aspell.scm7
-rw-r--r--gnu/packages/patches/aspell-gcc-compat.patch31
2 files changed, 3 insertions, 35 deletions
diff --git a/gnu/packages/aspell.scm b/gnu/packages/aspell.scm
index f0e0fbcc21..70d0561004 100644
--- a/gnu/packages/aspell.scm
+++ b/gnu/packages/aspell.scm
@@ -38,7 +38,7 @@
(define-public aspell
(package
(name "aspell")
- (version "0.60.6.1")
+ (version "0.60.8")
(source
(origin
(method url-fetch)
@@ -46,9 +46,8 @@
version ".tar.gz"))
(sha256
(base32
- "1qgn5psfyhbrnap275xjfrzppf5a83fb67gpql0kfqv37al869gm"))
- (patches (search-patches "aspell-default-dict-dir.patch"
- "aspell-gcc-compat.patch"))))
+ "1wi60ankalmh8ds7nplz434jd7j94gdvbahdwsr539rlad8pxdzr"))
+ (patches (search-patches "aspell-default-dict-dir.patch"))))
(build-system gnu-build-system)
(arguments
`(#:phases
diff --git a/gnu/packages/patches/aspell-gcc-compat.patch b/gnu/packages/patches/aspell-gcc-compat.patch
deleted file mode 100644
index 94c44f8fb6..0000000000
--- a/gnu/packages/patches/aspell-gcc-compat.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-Fix GCC7 warnings.
-
-Taken from upstream:
-https://git.savannah.gnu.org/cgit/aspell.git/commit/?id=8089fa02122fed0a6394eba14bbedcb1d18e2384
-
-diff --git a/modules/filter/tex.cpp b/modules/filter/tex.cpp
-index a979539..19ab63c 100644
---- a/modules/filter/tex.cpp
-+++ b/modules/filter/tex.cpp
-@@ -174,7 +174,7 @@ namespace {
-
- if (c == '{') {
-
-- if (top.in_what == Parm || top.in_what == Opt || top.do_check == '\0')
-+ if (top.in_what == Parm || top.in_what == Opt || *top.do_check == '\0')
- push_command(Parm);
-
- top.in_what = Parm;
-diff --git a/prog/check_funs.cpp b/prog/check_funs.cpp
-index db54f3d..89ee09d 100644
---- a/prog/check_funs.cpp
-+++ b/prog/check_funs.cpp
-@@ -647,7 +647,7 @@ static void print_truncate(FILE * out, const char * word, int width) {
- }
- }
- if (i == width-1) {
-- if (word == '\0')
-+ if (*word == '\0')
- put(out,' ');
- else if (word[len] == '\0')
- put(out, word, len);