summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-04-29 23:13:49 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-31 14:53:30 -0400
commit87465a718a3cd0bf3b73d254eb2b281173bd78c8 (patch)
tree7bdd40e3c45c2ed0f7e167c67fcc741be3fadbca /gnu/packages
parent4392bf589f0a654f71e245794bcafc1351f28943 (diff)
downloadguix-patches-87465a718a3cd0bf3b73d254eb2b281173bd78c8.tar
guix-patches-87465a718a3cd0bf3b73d254eb2b281173bd78c8.tar.gz
gnu: Remove python2-flake8.
* gnu/packages/python-xyz.scm (python2-flake8): Delete variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python-xyz.scm35
1 files changed, 10 insertions, 25 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index c45f8ef436..b38ecc6908 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -10862,35 +10862,20 @@ cyclomatic complexity of Python source code.")
"0y732h02n2aih8gzyfj4bbhg4jgahyv84mjwfindk2g6w45rka0s"))))
(build-system python-build-system)
(arguments
- `(#:phases
- (modify-phases %standard-phases
- (replace 'check
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (add-installed-pythonpath inputs outputs)
- (invoke "pytest" "-v"))))))
- (propagated-inputs
- (list python-pycodestyle python-entrypoints python-pyflakes
- python-mccabe))
- (native-inputs
- (list python-mock python-pytest))
+ `(#:phases (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (add-installed-pythonpath inputs outputs)
+ (invoke "pytest" "-v"))))))
+ (propagated-inputs (list python-pycodestyle python-entrypoints
+ python-pyflakes python-mccabe))
+ (native-inputs (list python-mock python-pytest))
(home-page "https://gitlab.com/pycqa/flake8")
- (synopsis
- "The modular source code checker: pep8, pyflakes and co")
+ (synopsis "The modular source code checker: pep8, pyflakes and co")
(description
- "Flake8 is a wrapper around PyFlakes, pep8 and python-mccabe.")
- (properties `((python2-variant . ,(delay python2-flake8))))
+ "Flake8 is a wrapper around PyFlakes, pep8 and python-mccabe.")
(license license:expat)))
-(define-public python2-flake8
- (let ((base (package-with-python2 (strip-python2-variant python-flake8))))
- (package/inherit base
- (propagated-inputs
- `(("python2-configparser" ,python2-configparser)
- ("python2-enum34" ,python2-enum34)
- ("python2-functools32" ,python2-functools32)
- ("python2-typing" ,python2-typing)
- ,@(package-propagated-inputs base))))))
-
(define-public python-flake8-3.8
(package
(inherit python-flake8)