summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-04-29 23:11:08 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-31 14:53:26 -0400
commit08063afd31562f71b7b3e12c270ab46230fa9b6a (patch)
tree1018fc14afc4c66301e8095ff41e82088485defc /gnu/packages
parentc3a8ee49bc924fdeec6b5258c573e93231e2d0bd (diff)
downloadguix-patches-08063afd31562f71b7b3e12c270ab46230fa9b6a.tar
guix-patches-08063afd31562f71b7b3e12c270ab46230fa9b6a.tar.gz
gnu: Remove python2-futures.
* gnu/packages/python-xyz.scm (python2-futures): Delete variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python-xyz.scm29
1 files changed, 0 insertions, 29 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 1342bb10a8..7d8eb7c2ea 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -14687,35 +14687,6 @@ in threaded applications. It includes timeout support from Python 3.3 but
otherwise matches 3.2’s API.")
(license license:psfl)))
-(define-public python2-futures
- (package
- (name "python2-futures")
- (version "3.2.0")
- (source
- (origin
- (method url-fetch)
- (uri (pypi-uri "futures" version))
- (sha256
- (base32
- "0rdjmmsab550kxsssdq49jcniz77zlkpw4pvi9hvib3lsskjmh4y"))))
- (build-system python-build-system)
- (arguments
- `(#:python ,python-2
- #:phases
- (modify-phases %standard-phases
- (replace 'check
- (lambda _
- (invoke "python" "test_futures.py")
- #t)))))
- (home-page "https://github.com/agronholm/pythonfutures")
- (synopsis
- "Backport of the concurrent.futures package from Python 3.2")
- (description
- "The concurrent.futures module provides a high-level interface for
-asynchronously executing callables. This package backports the
-concurrent.futures package from Python 3.2")
- (license license:bsd-3)))
-
(define-public python-promise
(package
(name "python-promise")