summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2022-05-20 09:48:45 +0200
committerRicardo Wurmus <rekado@elephly.net>2022-05-20 10:06:36 +0200
commit1f50f11aefe0fb1937cb15d4e327e0ffd94071d7 (patch)
treed350b8763a390620e0e303271e3fc5fa10436a55 /gnu/packages
parent62a4ed258c27d19bf168095981ebf7bb1d381051 (diff)
downloadguix-patches-1f50f11aefe0fb1937cb15d4e327e0ffd94071d7.tar
guix-patches-1f50f11aefe0fb1937cb15d4e327e0ffd94071d7.tar.gz
gnu: python-google: Add missing input.
* gnu/packages/python-web.scm (python-google)[propagated-inputs]: Add python-beautifulsoup4.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python-web.scm49
1 files changed, 49 insertions, 0 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 2a688b53df..ed047a7faa 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -4494,6 +4494,8 @@ users, gradebooks, and more.")
(build-system python-build-system)
(arguments
`(#:tests? #f)) ; There are no tests.
+ (propagated-inputs
+ (list python-beautifulsoup4))
(home-page "https://breakingcode.wordpress.com/")
(synopsis "Python bindings to the Google search engine")
(description "This package provides Python bindings for using the
@@ -6538,6 +6540,53 @@ through the network, it only deals with the implementation details of the
SOCKS protocols. It can be paired with any I/O library.")
(license license:expat)))
+(define-public python-msrest
+ (package
+ (name "python-msrest")
+ (version "0.6.21")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "msrest" version))
+ (sha256
+ (base32 "1n389m3hcsyjskzimq4j71nyw9pjkrp0n5wg1q2c4bfwpv3inrkj"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "pytest"
+ "-k"
+ ;; These attempt to connect to bing.com.
+ (string-append
+ "not test_basic_aiohttp"
+ " and not test_basic_async_requests"
+ " and not test_conf_async_requests"
+ " and not test_conf_async_trio_requests"
+ " and not test_basic_aiohttp"
+ " and not test_basic_async_requests"
+ " and not test_conf_async_requests"
+ " and not test_conf_async_trio_requests"))))))))
+ (propagated-inputs
+ (list python-aiohttp
+ python-certifi
+ python-isodate
+ python-requests
+ python-requests-oauthlib))
+ (native-inputs
+ (list python-httpretty
+ python-pytest
+ python-pytest-aiohttp
+ python-pytest-asyncio
+ python-pytest-trio))
+ (home-page "https://github.com/Azure/msrest-for-python")
+ (synopsis "AutoRest swagger generator Python client runtime.")
+ (description "This package provides the runtime library @code{msrest} for
+AutoRest-generated Python clients.")
+ (license license:expat)))
+
(define-public python-azure-nspkg
(package
(name "python-azure-nspkg")