summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2017-05-08 00:22:30 +0200
committerLudovic Courtès <ludo@gnu.org>2017-05-08 00:25:15 +0200
commit4b7917f2f3669e5ef34b4c2ef723fd596177f163 (patch)
tree03a1d040d274bd100a3e91610cc6780de5339b03 /gnu/packages
parentaf6e2385b3125924f34188d81370dd71cdbe9ddc (diff)
downloadguix-patches-4b7917f2f3669e5ef34b4c2ef723fd596177f163.tar
guix-patches-4b7917f2f3669e5ef34b4c2ef723fd596177f163.tar.gz
gnu: guix: Update snapshot.
* gnu/packages/package-management.scm (guix): Update to ba2260d. [version]: Take 7 characters from COMMIT. [arguments]: Pass 'ac_cv_guix_test_root' to #:configure-flags.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/package-management.scm17
1 files changed, 10 insertions, 7 deletions
diff --git a/gnu/packages/package-management.scm b/gnu/packages/package-management.scm
index 467613ef94..1d201f1893 100644
--- a/gnu/packages/package-management.scm
+++ b/gnu/packages/package-management.scm
@@ -73,18 +73,16 @@
;; Note: the 'update-guix-package.scm' script expects this definition to
;; start precisely like this.
(let ((version "0.12.0")
- (commit "25a49294caf2386e65fc1b12a2508324be0b1cc2")
- (revision 9))
+ (commit "ba2260dbbc5a3c915e2cbd54d93f2f3af2a864c3")
+ (revision 10))
(package
(name "guix")
- ;; Note: use a very short commit id; with a longer one, the limit on
- ;; hash-bang lines would be exceeded while running the tests.
(version (if (zero? revision)
version
(string-append version "-"
(number->string revision)
- "." (string-take commit 4))))
+ "." (string-take commit 7))))
(source (origin
(method git-fetch)
(uri (git-reference
@@ -92,7 +90,7 @@
(commit commit)))
(sha256
(base32
- "0p4rh0629j89v4ka5dsp70a1xrfhg7sxjjq54p68vw7x5dkann4a"))
+ "0nkwbblsnl7kv2n8jf8c6rl3a7dynaqxizhhni18vbnmvza35c79"))
(file-name (string-append "guix-" version "-checkout"))))
(build-system gnu-build-system)
(arguments
@@ -110,7 +108,12 @@
;; we don't keep a reference to Graphviz, whose
;; closure is pretty big (too big for the GuixSD
;; installation image.)
- "ac_cv_path_DOT_USER_PROGRAM=dot")
+ "ac_cv_path_DOT_USER_PROGRAM=dot"
+
+ ;; To avoid problems with the length of shebangs,
+ ;; choose a fixed-width and short directory name
+ ;; for tests.
+ "ac_cv_guix_test_root=/tmp/guix-tests")
#:parallel-tests? #f ;work around <http://bugs.gnu.org/21097>
#:modules ((guix build gnu-build-system)