summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-04-05 11:31:59 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-12 12:45:31 -0400
commitf761974b123d1129849dd2be11dab0893b4d5766 (patch)
tree4c93948353a118ba098f1e1f65b8f3bf5031ceb8 /gnu/packages
parent529318bd22373557c95e74e1ea9c5365c403af19 (diff)
downloadguix-patches-f761974b123d1129849dd2be11dab0893b4d5766.tar
guix-patches-f761974b123d1129849dd2be11dab0893b4d5766.tar.gz
gnu: Add python-jaraco-classes.
* gnu/packages/python-xyz.scm (python-jaraco-classes): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python-xyz.scm38
1 files changed, 38 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 0ae000d15b..a9d77fe84c 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -8557,6 +8557,44 @@ finding unresolved symbols in Python code and their corresponding imports.")
"@code{inotify-simple} is a simple wrapper around inotify library.")
(license license:bsd-3)))
+(define-public python-jaraco-classes
+ (package
+ (name "python-jaraco-classes")
+ (version "3.2.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "jaraco.classes" version))
+ (sha256
+ (base32 "0d6g7qvfv1jlzbzh6asprqdblqd59grvlvr3nwbdqdqrmwlbfm7d"))))
+ (build-system python-build-system)
+ (arguments
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ ;; Do not test the myproject.toml build as it tries to pull
+ ;; dependencies from the Internet.
+ (invoke "pytest" "-vv" "-k" "not project")))))))
+ (native-inputs
+ (list python-pytest
+ python-pytest-black
+ python-pytest-checkdocs
+ python-pytest-cov
+ python-pytest-enabler-bootstrap ;OK since not propagated
+ python-pytest-flake8
+ python-pytest-mypy
+ python-setuptools-scm
+ python-wheel))
+ (propagated-inputs (list python-more-itertools))
+ (home-page "https://github.com/jaraco/jaraco.classes")
+ (synopsis "Utility functions for Python class constructs")
+ (description "This Python library contains utility functions for Python
+class constructs.")
+ (license license:expat)))
+
;;; Variant used to break a cycle with python-pytest-enabler.
(define-public python-jaraco-context-bootstrap
(hidden-package