summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-04-06 00:16:46 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-12 12:45:32 -0400
commit59944e875af8be1f3501a5f9fd12c644cef4f9d5 (patch)
treeedf683cfe8e09ae1e91163ec71c9c8475c3d1c0c /gnu/packages
parent26d92095d6870c0d10ef3a0f16256d7979a8dba5 (diff)
downloadguix-patches-59944e875af8be1f3501a5f9fd12c644cef4f9d5.tar
guix-patches-59944e875af8be1f3501a5f9fd12c644cef4f9d5.tar.gz
gnu: Add python-jaraco-functools.
* gnu/packages/python-xyz.scm (python-jaraco-functools): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python-xyz.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index f586728ce9..458d0d58af 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -8667,6 +8667,36 @@ procedures.")
module with a few extra procedures.")
(license license:expat))))
+(define-public python-jaraco-functools
+ (package/inherit python-jaraco-functools-bootstrap
+ (name "python-jaraco-functools")
+ (arguments
+ (substitute-keyword-arguments
+ (package-arguments python-jaraco-functools-bootstrap)
+ ((#:tests? _ #f)
+ #t)
+ ((#:phases phases #~%standard-phases)
+ #~(modify-phases #$phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ ;; Do not test the myproject.toml build as it tries to pull
+ ;; dependencies from the Internet.
+ (invoke "pytest" "-vv" "-k" "not project"))))))))
+ (native-inputs
+ (modify-inputs
+ (package-native-inputs python-jaraco-functools-bootstrap)
+ (append python-jaraco-classes
+ python-pytest
+ python-pytest-black
+ python-pytest-checkdocs
+ python-pytest-cov
+ python-pytest-enabler-bootstrap ;OK since not propagated
+ python-pytest-flake8
+ python-pytest-mypy)))
+ (properties (alist-delete 'hidden? (package-properties
+ python-jaraco-functools-bootstrap)))))
+
(define-public python-jaraco-packaging
(package
(name "python-jaraco-packaging")