summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-08-22 13:55:34 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-08-22 14:08:54 +0300
commit5987855f21a5fb203503ddaef961b58e1b735290 (patch)
treee59e58de1c292be0733a6eeee5c9b1d623124759 /gnu/packages
parent0e55c4902b198c3260078001992ce013d2e18143 (diff)
downloadguix-patches-5987855f21a5fb203503ddaef961b58e1b735290.tar
guix-patches-5987855f21a5fb203503ddaef961b58e1b735290.tar.gz
gnu: python-jsonschema: Fix test suite.
* gnu/packages/python-xyz.scm (python-jsonschema)[arguments]: Adjust custom 'check phase to honor #:tests and to set the JSON_SCHEMA_TEST_SUTE environment variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python-xyz.scm6
1 files changed, 4 insertions, 2 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 3e94abd376..ca624b5d17 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -3334,8 +3334,10 @@ compare, diff, and patch JSON and JSON-like structures in Python.")
'(#:phases
(modify-phases %standard-phases
(replace 'check
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (invoke "trial" "jsonschema"))))))
+ (lambda* (#:key inputs outputs tests? #:allow-other-keys)
+ (when tests?
+ (setenv "JSON_SCHEMA_TEST_SUITE" "json")
+ (invoke "trial" "jsonschema")))))))
(native-inputs
`(("python-setuptools_scm" ,python-setuptools-scm)
("python-twisted" ,python-twisted)))