summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-04-05 10:53:21 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-12 12:45:27 -0400
commit21db2a0848a661883ebc9dfd53c125488541a835 (patch)
treede144dd62e92ee0282ea1ca57eede7f088bdf9a8 /gnu/packages
parent63a77de2fc3718e1c8967bbc1281e0735ac2e807 (diff)
downloadguix-patches-21db2a0848a661883ebc9dfd53c125488541a835.tar
guix-patches-21db2a0848a661883ebc9dfd53c125488541a835.tar.gz
gnu: Add python-types-toml.
* gnu/packages/python-xyz.scm (python-types-toml): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python-xyz.scm18
1 files changed, 18 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index f8ef15cea1..f1023c0563 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -29512,6 +29512,24 @@ async I/O support.")
"This package adds ANSI colors and decorations to your strings.")
(license license:isc)))
+(define-public python-types-toml
+ (package
+ (name "python-types-toml")
+ (version "0.10.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "types-toml" version))
+ (sha256
+ (base32 "10400bd3yv6rjfnq8galskkbpqz1sfx9sfgr5qwvw04270x4cjgr"))))
+ (build-system python-build-system)
+ (home-page "https://github.com/python/typeshed")
+ (synopsis "Typing stubs for TOML")
+ (description "This package contains typing stubs for TOML, a very small
+subset the Python stubs contained in the complete @code{typeshed}
+collection.")
+ (license license:asl2.0)))
+
(define-public python-types-ujson
(package
(name "python-types-ujson")