summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-04-05 13:20:45 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-12 12:45:28 -0400
commit08b524fa7850e03b15b8d47e8afce2fb5f53a00e (patch)
tree4486aca053cf1f459e8bb990396c780fe0a7525f /gnu/packages
parent21f29263f3572c4a273d9e548adb8c8c8882e445 (diff)
downloadguix-patches-08b524fa7850e03b15b8d47e8afce2fb5f53a00e.tar
guix-patches-08b524fa7850e03b15b8d47e8afce2fb5f53a00e.tar.gz
gnu: Add python-types-freezegun.
* gnu/packages/python-xyz.scm (python-types-freezegun): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python-xyz.scm18
1 files changed, 18 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index f7cae9e656..ef12d973e6 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -29585,6 +29585,24 @@ async I/O support.")
"This package adds ANSI colors and decorations to your strings.")
(license license:isc)))
+(define-public python-types-freezegun
+ (package
+ (name "python-types-freezegun")
+ (version "1.1.8")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "types-freezegun" version))
+ (sha256
+ (base32 "08g926s8343zwq140zcfwly3qfgmahm7lp0vgb3ics549b2hifzl"))))
+ (build-system python-build-system)
+ (home-page "https://github.com/python/typeshed")
+ (synopsis "Typing stubs for @code{freezegun}")
+ (description "This package contains typing stubs for for @code{freezegun}, a
+very small subset the Python stubs contained in the complete @code{typeshed}
+collection.")
+ (license license:asl2.0)))
+
(define-public python-types-toml
(package
(name "python-types-toml")