summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-04-05 14:41:19 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-12 12:45:30 -0400
commit040615d8f889ed51e238caad59cb6e1650d96aa1 (patch)
treea12340bce526303304b5398d380afc18c3f189df /gnu/packages
parentfc7fc0764b9deb41c9425f0c1596d2298cb3a935 (diff)
downloadguix-patches-040615d8f889ed51e238caad59cb6e1650d96aa1.tar
guix-patches-040615d8f889ed51e238caad59cb6e1650d96aa1.tar.gz
gnu: Add python-pip-run-bootstrap.
* gnu/packages/python-xyz.scm (python-pip-run-bootstrap): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python-xyz.scm43
1 files changed, 43 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 563ff63e7a..c622e1f93d 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -12658,6 +12658,49 @@ Python Package Index (PyPI).")
(define-public python2-pip
(package-with-python2 python-pip))
+;;; Variant used to break a dependency cycle with
+;;; python-pytest-perf-bootstrap.
+(define-public python-pip-run-bootstrap
+ (hidden-package
+ (package
+ (name "python-pip-run-bootstrap")
+ (version "8.8.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jaraco/pip-run")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0ycrjj3jgqcr9c2k7y8vprq65iblg0q0hvwz8zwi13gmb0ffds0c"))))
+ (build-system python-build-system)
+ (arguments
+ (list
+ #:tests? #f
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'build 'pretend-version
+ ;; The version string is usually derived via setuptools-scm, but
+ ;; without the git metadata available this fails.
+ (lambda _
+ (setenv "SETUPTOOLS_SCM_PRETEND_VERSION" #$version))))))
+ (native-inputs (list python-setuptools-scm))
+ (propagated-inputs (list python-autocommand python-path-bootstrap
+ python-packaging))
+ (home-page "https://github.com/jaraco/pip-run")
+ (synopsis "Dynamic dependency loader for Python")
+ (description "The @command{pip-run} command provides on-demand temporary
+package installation for a single interpreter run. It replaces this series of
+commands:
+@example
+$ virtualenv --python pythonX.X --system-site-packages /tmp/env
+$ /tmp/env/bin/pip install pkg1 pkg2 -r reqs.txt
+$ /tmp/env/bin/python ...
+$ rm -rf /tmp/env
+@end example")
+ (license license:expat))))
+
(define-public python-tlsh
(package
(name "python-tlsh")