summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2021-10-19 13:14:19 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-10-19 13:14:19 +0200
commitd6d8f34c4039ebbadace2ee8bdeed95a8546722c (patch)
treef27d6e67ac1b6ae9a6bc799c045b40b8aeffc369 /gnu/packages
parent39e9393b360160ca22d07305aadd6266a7b75f85 (diff)
downloadguix-patches-d6d8f34c4039ebbadace2ee8bdeed95a8546722c.tar
guix-patches-d6d8f34c4039ebbadace2ee8bdeed95a8546722c.tar.gz
gnu: emacs-company-quickhelp: Update to 2.3.0.
* gnu/packages/emacs-xyz.scm (emacs-company-quickhelp): Update to 2.3.0.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/emacs-xyz.scm44
1 files changed, 20 insertions, 24 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 1aa7e1d624..31fe24057f 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -6419,31 +6419,27 @@ for the current function or variable in the minibuffer.")
(license license:gpl3+)))
(define-public emacs-company-quickhelp
- ;; XXX: release version 2.3.0 is on an unmaintained branch for some reason,
- ;; so we use the latest 2.2.0 commit instead
- (let ((commit "479676cade80a9f03802ca3d956591820ed5c537")
- (revision "1"))
- (package
- (name "emacs-company-quickhelp")
- (version (git-version "2.2.0" revision commit))
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/expez/company-quickhelp")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32 "0hbqpnaf4hnin3nmdzmfj3v22kk9a97b6zssqs96ns36d9h52xcp"))))
- (build-system emacs-build-system)
- (propagated-inputs
- `(("emacs-pos-tip" ,emacs-pos-tip)
- ("emacs-company" ,emacs-company)))
- (home-page "https://github.com/expez/company-quickhelp")
- (synopsis "Popup documentation for completion candidates")
- (description "@code{company-quickhelp} shows documentation for the
+ (package
+ (name "emacs-company-quickhelp")
+ (version "2.3.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/expez/company-quickhelp")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "08ccsfvwdpzpj0gai3xrdb2bv1nl6myjkxsc5774pbvlq9nkfdvr"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("emacs-pos-tip" ,emacs-pos-tip)
+ ("emacs-company" ,emacs-company)))
+ (home-page "https://github.com/expez/company-quickhelp")
+ (synopsis "Popup documentation for completion candidates")
+ (description "@code{company-quickhelp} shows documentation for the
completion candidate when using the Company text completion framework.")
- (license license:gpl3+))))
+ (license license:gpl3+)))
(define-public emacs-math-symbol-lists
(package