summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-11-21 22:53:21 +0100
committerLudovic Courtès <ludo@gnu.org>2021-11-21 23:01:15 +0100
commitf862d7fb8d3656e7e0ec8ff5ef97db8e46536e93 (patch)
tree786b5616ee35090518d2e2b7fbde0f3ebe503155 /gnu/packages
parent84c3aafb5a18ad278bbb36df7b70849fe05789c8 (diff)
downloadguix-patches-f862d7fb8d3656e7e0ec8ff5ef97db8e46536e93.tar
guix-patches-f862d7fb8d3656e7e0ec8ff5ef97db8e46536e93.tar.gz
gnu: network-manager: Build with Meson 0.60.
This is another way to address <https://github.com/mesonbuild/meson/issues/9492> as suggested by Nirbheek Chauhan and Paolo Bonzini. * gnu/packages/patches/network-manager-meson.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/gnome.scm (network-manager)[source]: Use it. [arguments]: Remove #:meson.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/gnome.scm8
-rw-r--r--gnu/packages/patches/network-manager-meson.patch21
2 files changed, 24 insertions, 5 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index e6e6092593..82b002bd0d 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -7899,7 +7899,8 @@ users.")
(uri (string-append "mirror://gnome/sources/NetworkManager/"
(version-major+minor version) "/"
"NetworkManager-" version ".tar.xz"))
- (patches (search-patches "network-manager-plugin-path.patch"))
+ (patches (search-patches "network-manager-plugin-path.patch"
+ "network-manager-meson.patch"))
(sha256
(base32
"0jzmz0zw64dgvdn2g7pppr7bkywpbxcbdb1viv6p7zh2lnh3dax8"))))
@@ -7907,10 +7908,7 @@ users.")
(outputs '("out"
"doc")) ; 8 MiB of gtk-doc HTML
(arguments
- ;; Use meson-0.59, otherwise the custom rpaths are not registered
- ;; correctly (see: https://github.com/mesonbuild/meson/issues/9492).
- `(#:meson ,meson-0.59
- #:configure-flags
+ `(#:configure-flags
(let ((out (assoc-ref %outputs "out"))
(dhclient (search-input-file %build-inputs "/sbin/dhclient")))
(list
diff --git a/gnu/packages/patches/network-manager-meson.patch b/gnu/packages/patches/network-manager-meson.patch
new file mode 100644
index 0000000000..1056d40ede
--- /dev/null
+++ b/gnu/packages/patches/network-manager-meson.patch
@@ -0,0 +1,21 @@
+Since libnm-wwan.so is not just a loadable module but also a shared library
+that some plugin links against, build it as a shared library while avoiding
+'-Wl,--no-undefined':
+
+ https://github.com/mesonbuild/meson/issues/9492#issuecomment-973117289
+
+diff --git a/src/core/devices/wwan/meson.build b/src/core/devices/wwan/meson.build
+index 37ef738..18ac54f 100644
+--- a/src/core/devices/wwan/meson.build
++++ b/src/core/devices/wwan/meson.build
+@@ -4,8 +4,9 @@ wwan_inc = include_directories('.')
+
+ linker_script = join_paths(meson.current_source_dir(), 'libnm-wwan.ver')
+
+-libnm_wwan = shared_module(
++libnm_wwan = shared_library(
+ 'nm-wwan',
++ override_options: ['b_lundef=false'],
+ sources: files(
+ 'nm-service-providers.c',
+ 'nm-modem-broadband.c',