summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2020-07-24 22:43:37 +0200
committerMarius Bakke <marius@gnu.org>2020-07-25 16:16:10 +0200
commitca57048444b5a2d316818bb5bda35ae6e1fd2f61 (patch)
tree605998aea0c78d77c3890061e91dcb75ecf41141 /gnu/packages
parent9c71b3411d8d7da0437dbd83805899a747fd223b (diff)
downloadguix-patches-ca57048444b5a2d316818bb5bda35ae6e1fd2f61.tar
guix-patches-ca57048444b5a2d316818bb5bda35ae6e1fd2f61.tar.gz
gnu: libdrm: Update to 2.4.102.
* gnu/packages/patches/libdrm-realpath-virtio.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/xdisorg.scm (libdrm): Update to 2.4.102. [source](patches): Remove.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/patches/libdrm-realpath-virtio.patch42
-rw-r--r--gnu/packages/xdisorg.scm5
2 files changed, 2 insertions, 45 deletions
diff --git a/gnu/packages/patches/libdrm-realpath-virtio.patch b/gnu/packages/patches/libdrm-realpath-virtio.patch
deleted file mode 100644
index b7d85160b4..0000000000
--- a/gnu/packages/patches/libdrm-realpath-virtio.patch
+++ /dev/null
@@ -1,42 +0,0 @@
-Only check for for relative path on virtio devices. Otherwise it could
-break driver loading in some circumstances, notably the IceCat sandbox.
-
-https://gitlab.freedesktop.org/mesa/drm/-/issues/39
-
-Taken from upstream:
-https://gitlab.freedesktop.org/mesa/drm/-/commit/57df07572ce45a1b60bae6fb89770388d3abd6dd
-
-diff --git a/xf86drm.c b/xf86drm.c
---- a/xf86drm.c
-+++ b/xf86drm.c
-@@ -3103,15 +3103,18 @@ static int drmParseSubsystemType(int maj, int min)
- int subsystem_type;
-
- snprintf(path, sizeof(path), "/sys/dev/char/%d:%d/device", maj, min);
-- if (!realpath(path, real_path))
-- return -errno;
-- snprintf(path, sizeof(path), "%s", real_path);
-
- subsystem_type = get_subsystem_type(path);
-+ /* Try to get the parent (underlying) device type */
- if (subsystem_type == DRM_BUS_VIRTIO) {
-+ /* Assume virtio-pci on error */
-+ if (!realpath(path, real_path))
-+ return DRM_BUS_VIRTIO;
- strncat(path, "/..", PATH_MAX);
- subsystem_type = get_subsystem_type(path);
-- }
-+ if (subsystem_type < 0)
-+ return DRM_BUS_VIRTIO;
-+ }
- return subsystem_type;
- #elif defined(__OpenBSD__) || defined(__DragonFly__) || defined(__FreeBSD__)
- return DRM_BUS_PCI;
-@@ -3920,6 +3923,7 @@ process_device(drmDevicePtr *device, const char *d_name,
-
- switch (subsystem_type) {
- case DRM_BUS_PCI:
-+ case DRM_BUS_VIRTIO:
- return drmProcessPciDevice(device, node, node_type, maj, min,
- fetch_deviceinfo, flags);
- case DRM_BUS_USB:
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index 20702c3a4f..98d52cc392 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -497,7 +497,7 @@ rasterisation.")
(define-public libdrm
(package
(name "libdrm")
- (version "2.4.101")
+ (version "2.4.102")
(source (origin
(method url-fetch)
(uri (string-append
@@ -505,8 +505,7 @@ rasterisation.")
version ".tar.xz"))
(sha256
(base32
- "19vqbhqljhln0lrpnv3s7y3lkhsdcp76dl8bhqj3cis9ism1pwyx"))
- (patches (search-patches "libdrm-realpath-virtio.patch"))))
+ "0nx0bd9dhymdsd99v4ifib77yjirkvkxf5hzdkbr7qr8dhrzkjwb"))))
(build-system meson-build-system)
(arguments
`(#:configure-flags