summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2021-02-05 23:04:19 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-02-05 23:40:35 +0100
commite40d379de350f9a5bd5845548776fbf3c6f2f29a (patch)
tree4b5b85a57c8ebc32745660e99d365d68f07383cc /gnu/packages
parentd6f4d4fce625a617b53e5400122518378c0f6477 (diff)
downloadguix-patches-e40d379de350f9a5bd5845548776fbf3c6f2f29a.tar
guix-patches-e40d379de350f9a5bd5845548776fbf3c6f2f29a.tar.gz
gnu: rust-quick-error-1: Drop minor version from name.
* gnu/packages/crates-io.scm (rust-quick-error-1): Drop minor version from name. (rust-handlebars-2): (rust-humantime-1): (rust-proptest-0.10): (rust-proptest-0.9): (rust-proptest-0.8): (rust-proptest-0.7): (rust-proptest-0.3): (rust-resolv-conf-0.6): (rust-rusty-fork-0.3): (rust-rusty-fork-0.2): Apply renaming.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/crates-io.scm22
1 files changed, 11 insertions, 11 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index f2184c6e67..2d8b419184 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -15009,7 +15009,7 @@ IEEE 754-2008 binary16 type.")
("rust-log" ,rust-log-0.4)
("rust-pest" ,rust-pest-2)
("rust-pest-derive" ,rust-pest-derive-2)
- ("rust-quick-error" ,rust-quick-error-1.2)
+ ("rust-quick-error" ,rust-quick-error-1)
("rust-serde" ,rust-serde-1)
("rust-serde-json" ,rust-serde-json-1)
("rust-walkdir" ,rust-walkdir-2))
@@ -15972,7 +15972,7 @@ SystemTime}}.")
(arguments
`(#:skip-build? #t
#:cargo-inputs
- (("rust-quick-error" ,rust-quick-error-1.2))
+ (("rust-quick-error" ,rust-quick-error-1))
#:cargo-development-inputs
(("rust-chrono" ,rust-chrono-0.4)
("rust-rand" ,rust-rand-0.4)
@@ -26279,7 +26279,7 @@ This library mimics the Git way of showing progress.")
("rust-byteorder" ,rust-byteorder-1)
("rust-lazy-static" ,rust-lazy-static-1)
("rust-num-traits" ,rust-num-traits-0.2)
- ("rust-quick-error" ,rust-quick-error-1.2)
+ ("rust-quick-error" ,rust-quick-error-1)
("rust-rand" ,rust-rand-0.7)
("rust-rand-chacha" ,rust-rand-chacha-0.2)
("rust-rand-xorshift" ,rust-rand-xorshift-0.2)
@@ -26315,7 +26315,7 @@ including most strategies and the testing framework itself.")
("rust-byteorder" ,rust-byteorder-1)
("rust-lazy-static" ,rust-lazy-static-1)
("rust-num-traits" ,rust-num-traits-0.2)
- ("rust-quick-error" ,rust-quick-error-1.2)
+ ("rust-quick-error" ,rust-quick-error-1)
("rust-rand" ,rust-rand-0.6)
("rust-rand-chacha" ,rust-rand-chacha-0.1)
("rust-rand-xorshift" ,rust-rand-xorshift-0.1)
@@ -26348,7 +26348,7 @@ including most strategies and the testing framework itself.")
("rust-byteorder" ,rust-byteorder-1)
("rust-lazy-static" ,rust-lazy-static-1)
("rust-num-traits" ,rust-num-traits-0.2)
- ("rust-quick-error" ,rust-quick-error-1.2)
+ ("rust-quick-error" ,rust-quick-error-1)
("rust-rand" ,rust-rand-0.5)
("rust-regex-syntax" ,rust-regex-syntax-0.6)
("rust-rusty-fork" ,rust-rusty-fork-0.2)
@@ -26376,7 +26376,7 @@ including most strategies and the testing framework itself.")
("rust-bitflags" ,rust-bitflags-1)
("rust-lazy-static" ,rust-lazy-static-1)
("rust-num-traits" ,rust-num-traits-0.2)
- ("rust-quick-error" ,rust-quick-error-1.2)
+ ("rust-quick-error" ,rust-quick-error-1)
("rust-rand" ,rust-rand-0.4)
("rust-regex-syntax" ,rust-regex-syntax-0.4)
("rust-rusty-fork" ,rust-rusty-fork-0.2)
@@ -26402,7 +26402,7 @@ including most strategies and the testing framework itself.")
`(#:cargo-inputs
(("rust-bit-set" ,rust-bit-set-0.4)
("rust-lazy-static" ,rust-lazy-static-0.2)
- ("rust-quick-error" ,rust-quick-error-1.2)
+ ("rust-quick-error" ,rust-quick-error-1)
("rust-rand" ,rust-rand-0.3)
("rust-regex-syntax" ,rust-regex-syntax-0.4))
#:cargo-development-inputs
@@ -26736,7 +26736,7 @@ compliant email address validation.")
(description "This package provides a quasi-quoting macro system.")
(license (list license:expat license:asl2.0))))
-(define-public rust-quick-error-1.2
+(define-public rust-quick-error-1
(package
(name "rust-quick-error")
(version "1.2.3")
@@ -28754,7 +28754,7 @@ uses finite automata and guarantees linear time matching on all inputs.")
(arguments
`(#:tests? #f ; Not all test files included.
#:cargo-inputs
- (("rust-quick-error" ,rust-quick-error-1.2)
+ (("rust-quick-error" ,rust-quick-error-1)
("rust-hostname" ,rust-hostname-0.3))))
(home-page "https://github.com/tailhook/resolv-conf")
(synopsis "Parser for /etc/resolv.conf")
@@ -30499,7 +30499,7 @@ rustc compiler version.")
(arguments
`(#:cargo-inputs
(("rust-fnv" ,rust-fnv-1)
- ("rust-quick-error" ,rust-quick-error-1.2)
+ ("rust-quick-error" ,rust-quick-error-1)
("rust-tempfile" ,rust-tempfile-3)
("rust-wait-timeout" ,rust-wait-timeout-0.2))))
(home-page "https://github.com/altsysrq/rusty-fork")
@@ -30525,7 +30525,7 @@ sub-processes using a fork-like interface.")
`(#:skip-build? #t
#:cargo-inputs
(("rust-fnv" ,rust-fnv-1)
- ("rust-quick-error" ,rust-quick-error-1.2)
+ ("rust-quick-error" ,rust-quick-error-1)
("rust-tempfile" ,rust-tempfile-3)
("rust-wait-timeout" ,rust-wait-timeout-0.2))))))