summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2021-06-17 10:18:30 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2021-12-30 21:32:40 +0100
commitde3efe67b1601769fd123bf125ab00bf0ca84c22 (patch)
treef5d27b0f68e17d94496d654244fa2fef2b55abe6 /gnu/packages
parent42bf93ab8447dc92ced3e8f55ea17348434501c7 (diff)
downloadguix-patches-de3efe67b1601769fd123bf125ab00bf0ca84c22.tar
guix-patches-de3efe67b1601769fd123bf125ab00bf0ca84c22.tar.gz
gnu: Add rust-fallible-collections-0.3.
* gnu/packages/crates-io.scm (rust-fallible-collections-0.3): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/crates-io.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index efa2515622..1cfeed98f4 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -18237,6 +18237,28 @@ a result when an allocation error occurs, ala
fallible format macro.")
(license (list license:expat license:asl2.0))))
+(define-public rust-fallible-collections-0.3
+ (package
+ (name "rust-fallible-collections")
+ (version "0.3.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "fallible_collections" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "1shgcljh6pliv1b1qk6knk2hzig5ah76hx01f1icpgkiqp6fi6cm"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:skip-build? #t
+ #:cargo-inputs
+ (("rust-hashbrown" ,rust-hashbrown-0.9))))
+ (home-page "https://github.com/vcombey/fallible_collections.git")
+ (synopsis "Fallible allocation API for standard collections")
+ (description "This crate adds fallible allocation API to standard
+collections.")
+ (license (list license:expat license:asl2.0))))
+
(define-public rust-failure-0.1
(package
(name "rust-failure")